Bug 785729 - argyllcms: udev rules - invalid 'plugdev' group
argyllcms: udev rules - invalid 'plugdev' group
Status: CLOSED DUPLICATE of bug 859244
Product: Fedora
Classification: Fedora
Component: argyllcms (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
RejectedBlocker
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 08:37 EST by Kay Sievers
Modified: 2012-10-24 12:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: argyllcms-1.3.6-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 09:42:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kay Sievers 2012-01-30 08:37:14 EST
Please remove:
  MODE="660", GROUP="plugdev"

The group 'plugdev' is a misguided Ubuntu-only feature to solve hotplug device
permissions. Other distributions do not need this, and should not start using
any group assignments.

Using unknown users in udev rules can render the entire system unusable. It
might not be able to bootup in LDAP or other and network directory
configurations.
Comment 1 Kay Sievers 2012-03-18 17:44:37 EDT
Using unknown system groups in the boot-critical path is known to cause
serious issues for some setups which use directory servers to resolve
names.

A single wrong udev rule can render the entire system un-bootable. Therefore, installing udev rules comes with a certain responsibility; such an issue can
not be ignored for that long. This needs to be fixed now! Please fix the rules
or drop the rules file entirely if in doubt.

Thanks!
Comment 2 Adam Williamson 2012-03-19 17:28:51 EDT
Discussed at 2012-03-19 QA meeting, acting as a blocker review meeting. This bug is rejected as a Beta blocker (and would be rejected as a Final blocker), as argyllcms is not installed in a default package set, nor in fact in *any* easily-selectable package set (it's Optional in comps), nor on either of the supported desktop live images. As this is very unlikely to affect an initial installation, it doesn't merit blocker status.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Fedora Update System 2012-03-22 12:58:48 EDT
argyllcms-1.3.6-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/argyllcms-1.3.6-2.fc17
Comment 4 Fedora Update System 2012-03-22 20:39:16 EDT
Package argyllcms-1.3.6-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing argyllcms-1.3.6-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4440/argyllcms-1.3.6-2.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-11 22:56:58 EDT
argyllcms-1.3.6-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Colin Macdonald 2012-06-03 03:37:07 EDT
I think I still see this problem with argyllcms-1.4.0.

# grep /lib/udev/rules.d -r -i -e plugdev
55-Argyll.rules:# Otherwise, restrict access to members of the plugdev group
55-Argyll.rules:ENV{COLOR_MEASUREMENT_DEVICE}=="*?", ENV{ACL_MANAGE}!="*?", MODE="660", GROUP="plugdev"

# yum list argyllcms*
Loaded plugins: changelog, langpacks, presto, refresh-packagekit
Installed Packages
argyllcms.i686                                             1.4.0-2.fc17                                          @updates-testing
Available Packages
argyllcms-doc.i686                                         1.4.0-1.fc17                                          updates
Comment 7 Kay Sievers 2012-07-15 15:50:23 EDT
Gah, these broken rules are still in rawhide.

This got fixed F17 only, but not in master/rawhide?
Comment 8 Matthias Clasen 2012-08-13 10:16:07 EDT
Still happening in post-branch F18.

But the line before the problematic plugdev one,

TEST=="/lib/udev/udev-acl", TEST=="/var/run/ConsoleKit/database", ENV{COLOR_MEASUREMENT_DEVICE}=="*?", ENV{ACL_MANAGE}="1"

is not really right either, or is it ?
Shouldn't that be TAG+="uaccess"?
Comment 9 Kay Sievers 2012-08-14 09:03:31 EDT
The ConsoleKit stuff should be entirely removed, yes,

Nothing should directly set internal udev tags, they might change whenever
needed.
There is a COLOR_MEASUREMENT_DEVICE flag supported, which is probably intended
to be used here?
Comment 10 Paulo Fidalgo 2012-09-10 05:24:26 EDT
I still have this on F17 (with the latest updates).
Comment 11 Peter Larsen 2012-09-10 14:53:09 EDT
(In reply to comment #10)
> I still have this on F17 (with the latest updates).

Me too. I don't see a reference to plugdev in /etc/udev*
Comment 12 Paulo Fidalgo 2012-09-11 04:14:24 EDT
(In reply to comment #10)
> I still have this on F17 (with the latest updates).

without udev references on /etc/udev but with the same references as comment #6 om /lib/udev/rules.d
Comment 13 Gwyn Ciesla 2012-09-21 09:42:45 EDT

*** This bug has been marked as a duplicate of bug 859244 ***
Comment 14 Fedora Update System 2012-10-24 12:22:56 EDT
argyllcms-1.4.0-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/argyllcms-1.4.0-6.fc18

Note You need to log in before you can comment on or make changes to this bug.