Bug 785751 - RFE: Add additional desktop files for packages to show up in the menus on GNOME 3 and KDE
RFE: Add additional desktop files for packages to show up in the menus on GNO...
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Ruediger Landmann
: FutureFeature
: 902500 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 09:34 EST by eric@christensenplace.us
Modified: 2014-08-08 21:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 21:28:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2012-01-30 09:34:46 EST
Description of problem: In a Publican-created package the included desktop file only works on GNOME 2, LXDE, and XFCE.  GNOME 3 and KDE require small tweaks to their desktop files for them to be utilized.

Version-Release number of selected component (if applicable): 2.8

How reproducible: Always

I'm going to try to pull examples of desktop files that work for each environment for use.
Comment 1 Jeff Fearn 2012-12-16 22:33:53 EST
From a short inspection on Fedora 17:

Gnome2:

Categories=Documentation;

KDE4:

Categories=Documentation;System;

KFCE;LXDE:

Categories=Documentation;S-Red-Hat-Base;

Gnome3:

Categories=Application;Utility;

Not sure we are interested in inheriting this kind of maintenance nightmare.
Comment 2 Jeff Fearn 2013-04-18 00:02:19 EDT
*** Bug 902500 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Fearn 2014-07-10 19:16:58 EDT
I'm not sure we need to do anything for gnome3. When I hit the app key and start typing in a book name the installed desktop books are listed, selecting them opens the docs in the default web browser.

What else is required?
Comment 5 Eric Christensen 2014-08-08 21:28:13 EDT
Yeah, we're not using this functionality now so I haven't messed with this anymore.

Note You need to log in before you can comment on or make changes to this bug.