Bug 78578 - I845G in IBM NetVista A30 RedHat 7.3 Black Screen of Death
I845G in IBM NetVista A30 RedHat 7.3 Black Screen of Death
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-25 17:47 EST by Conrad Stucki
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-25 17:47:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Stucki 2002-11-25 17:47:13 EST
Description of Problem: IBM NetVista A30 8313,8315 (maybe all) with Intel 
82845G on motherboard. Black Screen of Death in (CTL)(ALT)(F7) in init 5 as 
described below. Only a warm or cold reboot can fix this.


Version-Release number of selected component (if applicable):
IBM 8313-52U with shipped BIOS (28a) and flashed to 11/04/02 version 24jt31a.
IBM 8315-11U with shipped BIOS (28a) and flashed to 11/04/02 version 24jt31a.
Both with Red Hat Kernels 2.4.18-3 and 2.4.18-18.7.
note: BIOS update fixed i810 sound.
note: kernel update turned on dma reported in hdparm.


How Reproducible: Every Time.


Steps to Reproduce:
1. Log Off of first KDE session after system boot.
2. Restart X server at KDE login.
3. Switching from (ctrl)(alt)(K1-6) to (K7) after the reverse, whether logged 
into KDE or not.

Actual Results: Monitor briefly turns off (1 sec) and then turns on black.
There is no problem switching back to text mode in (ctrl)(alt)(K1-6)


Expected Results: X Window Operation.


Additional Information: IBM Bios set to 8192 Bytes of Memory, tried all 
possible apertures from 32 to 256 mb, anaconda sets vesa driver and finds 4096 
bytes of memory, display mode is set to 1024x768 with a color depth of 16 
(tried 8). Xconfigurator cannot find it. X11 runs perfectly until one of the 
above described events happen.

Currently attempting XFree86-4.2.99.2-0.20021110.10.i386.rpm but havn't figured 
out all the dependencies yet. Have yet to find an alternate plug in graphics 
card that will boot.

Conrad Stucki  engineering@energycontrolsystems.com
Comment 1 Mike A. Harris 2002-11-25 17:53:14 EST
Intel i845 Graphics hardware is totally unsupported in both
Red Hat Linux 7.3 and 8.0.  In 8.0 there is some code backported
from CVS which I did in hopes that it would work for someone,
and it has worked for a few people, but it is just something I
did for goodwill of whoever it happens to work for, and is not
officially supported by Red Hat.

XFree86 4.3.0 will be the first XFree86 release to support the i845
hardware.  In the mean time, your only option is to use an alternate
graphics adaptor.

Closing bug as NOTABUG, since the hardware is not supported, which
is not a bug.
Comment 2 Conrad Stucki 2002-12-03 15:17:47 EST
When linux doesn't support a chip such as the 845G, it defaults to the "vesa" 
driver. It is this "vesa" driver that fails to re-start as shown above.

Intel provided a default vesa mode on the 845G chipset, and the vesa driver 
should have supported it out of the box. It almost did. This would have made us 
happy. Perhaps this should be brought up to XFree86.org. I believe support for 
vesa modes should continue for future releases of linux for future unsupported 
chipsets with vesa default modes.

The Release 8.0 package does work with the 845G chipset on these machines, 
although at 84-85 Hz at 1024x768, above the maximum 75 Hz entered in XF86Config 
for the LCD screens we ship. Our workaround is selected XFree86 rpm's to 
upgrade 8.0 to work with these monitors.

Thank you for the information.

Conrad Stucki    engineering@energycontrolsystems.com
Comment 3 Mike A. Harris 2002-12-04 19:04:10 EST
As I said...  i845 is not supported.  Unsupported hardware is totally
unsupported.  The existing code in 8.0 was an effort done by me in my
own unpaid personal time, in hopes that i845 would work minimally for
at least someone.  It is provided as-is and unsupported.

Unsupported hardware will get no official attention until it is
officially supported.  The solution for users and customers is to purchase
hardware which is supported.

Sorry there is nothing I am able to do for you.  XFree86 4.3.0 will support
this hardware when it is released.  I'd also like to note that the video
modes available in the vesa driver are the ones provided by the VESA
VBE BIOS in the video card.  If a mode isn't available, then it is not
in the BIOS.

Note You need to log in before you can comment on or make changes to this bug.