Bug 785848 - Intel Centrino Ultimate-N 6300 frequently loses connection
Intel Centrino Ultimate-N 6300 frequently loses connection
Status: CLOSED DUPLICATE of bug 785239
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 13:59 EST by Joel Uckelman
Modified: 2012-01-31 13:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 13:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2012-01-30 13:59:04 EST
Description of problem:

My Thinkpad W520 has an Intel Centrino Ultimate-N 6300 wireless card. With kernel 3.2.2-1, I periodically become unable to ping anything on the network beyond the wireless card itself---not even the access point. This typically happens anywhere between 30 seconds and 10 minutes after connecting to the access point. Despite this, NetworkManager still shows that I am connected to the AP. The only way I've found to restore connectivity is to toggle the wireless switch on the side of the laptop. This makes the wireless unusable for most purposes, as nothing which takes more than about 30 seconds to transmit is sure to complete.

This was not a problem with kernel 3.2.1-3 or earlier. I'm certain it's not a issue with the access point, as I don't have the problem if I boot with 3.2.1-3, nor are any of the other devices using this AP having difficulties. 


Version-Release number of selected component (if applicable):

kernel-3.2.2-1.fc16.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Connect to the AP.
2. Do something which causes network traffic.
  
Actual results:

Wireless traffic ceases until kill switch is toggled.

Expected results:

The wireless should remain active.


Additional information:

I haven't noticed any unusual messages in /var/log/messages or dmesg, other than ones like this:

Jan 29 13:48:28 scylla kernel: [  189.762478] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = c0:25:06:55:ae:fe tid = 0
Jan 29 19:34:02 scylla kernel: [ 2073.503663] iwlwifi 0000:03:00.0: Queue 12 stuck for 2000 ms.

I'm happy to provide whatever additional information is needed for troubleshooting the problem.
Comment 1 Josh Boyer 2012-01-30 14:13:42 EST
Can you test this kernel:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3746937
Comment 2 Joel Uckelman 2012-01-31 12:42:33 EST
(In reply to comment #1)
> Can you test this kernel:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3746937

I have more than an hour of uptime with this kernel now and haven't needed to reset the wireless card once. This kernel seems ok.
Comment 3 Joel Uckelman 2012-01-31 12:54:18 EST
I'm still getting a lot of these in dmesg with the test kernel, however:

[ 4968.337333] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = c0:25:06:55:ae:fe tid = 0

I don't know what this means, so I'm not sure whether this is normal, or indicates some kind of misbehavior.
Comment 4 John W. Linville 2012-01-31 13:47:45 EST

*** This bug has been marked as a duplicate of bug 785239 ***

Note You need to log in before you can comment on or make changes to this bug.