Bug 785952 - chown verbose reports incorrect retained user:group for objects not matched to with --from=
chown verbose reports incorrect retained user:group for objects not matched t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 20:09 EST by Tero Nieminen
Modified: 2012-02-08 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version: coreutils-8.12-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-08 17:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tero Nieminen 2012-01-30 20:09:56 EST
Description of problem:
F16/Chown command when used together with options -v and --from= prints out incorrect information on retained owner and group for targets left untouched due to not matching arguments of --from: it prints out the owner:group you tried to change to instead of the actual retained owner and group. bug-coreutils@gnu.org confirmed that this does not occur on stock GNU/coreutils - at least as of coreutils-8.15. They also confirmed F16/coreutils-8.12-2 was affected.

Version-Release number of selected component (if applicable):
coreutils-8.12-2.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1.sudo su -
2.mkdir test
3.chown 500:500 test
4.chown -v --from=600:600 1000:1000 test

Actual results:

Any object not matched with --from= produces output like:
ownership of `test' retained as 1000:1000

Expected results:
printout: ownership of `test' retained as 500:500

Additional info:

The non-matched objects do retain their original owner and group.

The output is the same for non-root users as well. The problem only seems to lie in the verbose printout of chown: the actual owner change itself as well as the --from matching would appear to be unaffected (haven't tested extensively though). The incorrect verbose output can, nonetheless, be quite confusing if the verbose output is actually used for something, like verifying operation of "chown -R" on large batch on files for instance.
Comment 1 Pádraig Brady 2012-01-30 20:44:59 EST
Yep this was fixed in 8.13
http://git.sv.gnu.org/cgit/coreutils.git/commit/?id=6b282e7510ca8d
Comment 2 Ondrej Vasik 2012-01-31 01:38:09 EST
And update for this is alredy submitted - see https://admin.fedoraproject.org/updates/FEDORA-2012-1031/coreutils-8.12-6.fc16
Comment 3 Fedora Update System 2012-01-31 04:49:12 EST
coreutils-8.12-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-1031/coreutils-8.12-6.fc16
Comment 4 Fedora Update System 2012-02-08 17:59:59 EST
coreutils-8.12-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.