Bug 78601 - XMMS runs as root, not user
Summary: XMMS runs as root, not user
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 06:56 UTC by Rob Blomquist
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-26 13:26:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Blomquist 2002-11-26 06:56:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1) Gecko/20020826

Description of problem:
I cannot play anything with XMMS as a user, I can as root.
As user, I get a message box:

"Can't Open Audio" please check that:

You have the correct output plugin selected.
No other programs are blocking the soundcard
Your soundcard is configured properly.

I have checked that the preferences of my root and user are the same. OSS
driver, xmms-mpg123 installed.

I can only imagine that this is a preferences problem. I just can't figure out
where.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in as user.
2.Start KDE
3.Start XMMS
4.Listen to the sound of nothing
5.run XMMS from root prompt
6.Listen to tunes

Actual Results:  I got nothing as user, followed by blissfull tunes as root

Expected Results:  User should be able to hear tunes.

Additional info:

Comment 1 Michael Lee Yohe 2002-11-26 13:26:25 UTC
As user, produce the following:

First:
What is your output plugin?  Is it configured to use ESD?  The enlightened sound
daemon is the fundamental multiplexer for Gnome - I don't know if Red Hat's KDE
is setup to invoke the esd daemon upon startup - KDE uses ARts to handle their
sound multiplexing (esd can be patched to send all audio data to ARts, but I
don't figure Red Hat would do this since it is kind of hokey).

Configure XMMS, instead, to use the OSS driver (which works with most sound
cards).  Be default, it will send all audio data to /dev/dsp.  I would not think
that the configuration for XMMS would differ greatly from a normal user - but
it's worth a look.

Second, you should see if the permissions on your audio device can accomodate a
normal user:
$ ls -laF /dev/dsp
crw-------    1 myohe    root      14,   3 Aug 30 18:31 /dev/dsp
$ ls -laF /dev/audio
crw-------    1 myohe    root      14,   4 Aug 30 18:31 /dev/audio

Verify that your normal user has read/write permissions to the local device. 
These should be "transmogrified" when you login locally to the workstation.

Comment 2 Bill Nottingham 2002-11-26 16:31:15 UTC
This is not an xmms issue; you need to:

a) check the permissions on your sound device (/dev/dsp)
b) make sure that your output plugin (esd, oss, arts) matches your environment

Comment 3 Rob Blomquist 2002-11-27 06:15:55 UTC
I had all my permissions set to work. I found in /etc/security/console.perms 
that <sound> was only being configured for root, not other users. 
 
Yes, this is not an XMMS issue, its a RH issue though. Shame on RH for issuing 
a distro with problems like this.


Note You need to log in before you can comment on or make changes to this bug.