Bug 786023 - /lib/isc/heap.c:241: REQUIRE(index >= 1 && index <= heap->last) failed
/lib/isc/heap.c:241: REQUIRE(index >= 1 && index <= heap->last) failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 03:30 EST by Eddie Lania
Modified: 2012-11-14 06:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 06:45:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2012-01-31 03:30:23 EST
Description of problem: ../lib/isc/heap.c:241: REQUIRE(index >= 1 && index <= heap->last) failed


Version-Release number of selected component (if applicable):

dhcp-4.2.3-6.P2.fc16.i686


How reproducible: Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Jan 31 09:24:07 ls2ka dhcpd: Solicit message from fe80::168f:c6ff:fe88:7f31 port 546, transaction ID 0xEF08A900
Jan 31 09:24:07 ls2ka dhcpd[3853]: Solicit message from fe80::168f:c6ff:fe88:7f31 port 546, transaction ID 0xEF08A900
Jan 31 09:24:07 ls2ka dhcpd: Sending Advertise to fe80::168f:c6ff:fe88:7f31 port 546
Jan 31 09:24:07 ls2ka dhcpd[3853]: Sending Advertise to fe80::168f:c6ff:fe88:7f31 port 546
Jan 31 09:24:07 ls2ka dhcpd: Request message from fe80::168f:c6ff:fe88:7f31 port 546, transaction ID 0x87DDB200
Jan 31 09:24:07 ls2ka dhcpd[3853]: Request message from fe80::168f:c6ff:fe88:7f31 port 546, transaction ID 0x87DDB200
Jan 31 09:24:07 ls2ka dhcpd[3853]: ../../../lib/isc/heap.c:241: REQUIRE(index >= 1 && index <= heap->last) failed, back trace
Jan 31 09:24:07 ls2ka dhcpd[3853]: #0 0xb7562a7c in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #1 0xb75629c5 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #2 0xb75911d1 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #3 0xb7782bfa in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #4 0xb777dbbf in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #5 0xb77815b6 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #6 0xb778245b in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #7 0xb77a3f03 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #8 0xb77926fe in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #9 0xb76e7d05 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #10 0xb758645d in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #11 0xb758e066 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #12 0xb7592110 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #13 0xb757aa7a in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #14 0xb7794f71 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #15 0xb773e4cf in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #16 0xb73676b3 in ??
Jan 31 09:24:07 ls2ka dhcpd[3853]: #17 0xb773f351 in ??
Jan 31 09:24:07 ls2ka systemd[1]: dhcpd6.service: main process exited, code=killed, status=6
Jan 31 09:24:07 ls2ka systemd[1]: Unit dhcpd6.service entered failed state.



Expected results:

No such error

Additional info:
Comment 1 Jiri Popelka 2012-01-31 06:00:31 EST
This seems to be a problem in BIND libraries.
BIND 9.8.2rc1 reached stable yesterday. What does 'rpm -q bind-libs-lite' show ?

Please also install (debuginfo-install bind dhcp) some debuginfo packages to get better stacktrace.
Comment 2 Jiri Popelka 2012-01-31 06:26:45 EST
I'm not able to reproduce it here with
dhcp-4.2.3-6.P2.fc16.x86_64
bind-libs-lite-9.8.2-0.2.rc1.fc16.x86_64

Jan 31 12:21:42 f16a dhcpd[1350]: Solicit message from fe80::5054:ff:fe2b:cd68 port 546, transaction ID 0xE036B100
Jan 31 12:21:42 f16a dhcpd[1350]: Picking pool address 3ffe:501:ffff:1::167
Jan 31 12:21:42 f16a dhcpd[1350]: Sending Advertise to fe80::5054:ff:fe2b:cd68 port 546
Jan 31 12:21:43 f16a dhcpd[1350]: Request message from fe80::5054:ff:fe2b:cd68 port 546, transaction ID 0xF407F000
Jan 31 12:21:43 f16a dhcpd[1350]: Sending Reply to fe80::5054:ff:fe2b:cd68 port 546
Comment 3 Eddie Lania 2012-01-31 09:44:55 EST
I emptied the file /var/lib/dhcpd6.leases and afterwards restarted dhcpd6.service.

And now it's up and running again.

Must have been something in the old leases file.
Comment 4 Adam Tkac 2012-01-31 10:21:23 EST
(In reply to comment #3)
> I emptied the file /var/lib/dhcpd6.leases and afterwards restarted
> dhcpd6.service.
> 
> And now it's up and running again.
> 
> Must have been something in the old leases file.

We cannot do much without steps to reproduce or without core dump, in this case. Closing for now, if it happens again please reopen this ticket and attach leases file and/or core dump. Thank you in advance!
Comment 6 Eddie Lania 2012-09-01 16:17:23 EDT
The dhcpd6 service keeps crashing.

According to this thread at isc https://lists.isc.org/pipermail/dhcp-users/2012-February/015024.html there is some work being done.

I see no dhcp updates here however.

Please provide an updated version of the dhcp rpm package.
Comment 7 Eddie Lania 2012-09-02 08:31:17 EDT
PS: DHCP 4.2.4-P1 is the latest production release of ISC DHCP 4.2
Comment 8 Jiri Popelka 2012-09-03 06:44:50 EDT
Hi Eddie,

I can't find any note about this bug in the changelog to 4.2.4, but you can test this scratch-build of 4.2.4-P1 (it's what we ship with F17 rebuilt for F16).
http://koji.fedoraproject.org/koji/taskinfo?taskID=4447791

See also
https://lists.isc.org/pipermail/dhcp-users/2012-September/015964.html
Comment 9 Adam Tkac 2012-09-13 11:35:31 EDT
Is this bug still reproducible? If not, we can go ahead and close this ticket.
Comment 10 Eddie Lania 2012-09-14 09:15:53 EDT
My apologizes but i haven't been able to install the koji build.

Can you push it to testing repo?
Comment 11 Adam Tkac 2012-09-14 09:28:52 EDT
Jirka,

would it be possible to update dhcp in F16 to 4.2.4-P2, please? If not, we can leave this open and close it later, when Eddie updates to F17...
Comment 12 Jiri Popelka 2012-09-16 04:23:52 EDT
(In reply to comment #10)
> My apologizes but i haven't been able to install the koji build.

That's because the scratch-builds have already been deleted. Try these:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4487671

(In reply to comment #11)
> would it be possible to update dhcp in F16 to 4.2.4-P2, please? If not, we
> can leave this open and close it later, when Eddie updates to F17...

If Eddie finds out that 4.2.4 fixes the problem, then yes. But the changelog doesn't say anything like that.
Comment 13 Eddie Lania 2012-09-16 10:56:06 EDT
I have installed the koji builds.

I will report back in a week.
Comment 14 Eddie Lania 2012-09-22 11:24:19 EDT
I am not seeing this crash anymore now. Problem seems to be fixed.
Comment 15 Adam Tkac 2012-09-24 06:48:41 EDT
Reassigning to dhcp because it is correct component for this bug.
Comment 16 Fedora Update System 2012-09-24 12:50:16 EDT
dhcp-4.2.4-1.P2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-14076/dhcp-4.2.4-1.P2.fc16
Comment 17 Fedora Update System 2012-10-02 23:20:56 EDT
dhcp-4.2.4-1.P2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.