Bug 786037 - --skipcopy copied files
Summary: --skipcopy copied files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-31 09:08 UTC by Samuel Sieb
Modified: 2012-05-08 04:32 UTC (History)
6 users (show)

Fixed In Version: livecd-tools-17.11-1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 04:32:58 UTC
Type: ---


Attachments (Terms of Use)

Description Samuel Sieb 2012-01-31 09:08:41 UTC
I had setup a live system on a USB drive, but the MBR wasn't setup for some reason, so I wanted to use the --reset-mbr option.  I didn't have the source ISO image with me and there was no way to not provide one to the command, so I just picked one I had around.  The description of the --skipcopy option implies that it wouldn't actually write anything so I felt safe using a different image.

My command:
livecd-iso-to-disk --reset-mbr --skipcopy --noverify Fedora-16-i386-netinst.iso /dev/sdb1

Result:
/root/Fedora-16-i386-netinst.iso uses initrd.img w/o install.img
Copying DVD image to target device.
Updating boot config file
Installing boot loader
Target device is now set up with a Live image!

Tried booting it, got the installer boot menu!  As far as I can tell, it put the kernel and initrd.img from the provided ISO image in, renamed the existing ones with a 0 at the end, and changed the syslinux.cfg.

Is this the expected behaviour?  I expected it to do nothing but fix the MBR.  If this is expected, then I would ask for an option just for fixing the MBR.

Comment 1 Brian Lane 2012-04-16 22:44:21 UTC
The dvd files shouldn't have been copied with --skipcopy, but even with that you can't really count on using a different iso to repair things since the config files always get rewritten.

Comment 2 Fedora Update System 2012-04-17 01:00:20 UTC
livecd-tools-16.12-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.12-1.fc16

Comment 3 Fedora Update System 2012-04-17 01:01:24 UTC
livecd-tools-17.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.8-1.fc17

Comment 4 Fedora Update System 2012-04-18 19:43:26 UTC
Package livecd-tools-16.12-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-16.12-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6062/livecd-tools-16.12-1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-04-24 22:14:37 UTC
livecd-tools-17.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.9-1.fc17

Comment 6 Fedora Update System 2012-04-25 18:08:43 UTC
livecd-tools-16.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.13-1.fc16

Comment 7 Fedora Update System 2012-04-26 22:10:22 UTC
livecd-tools-17.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.10-1.fc17

Comment 8 Fedora Update System 2012-05-03 23:18:56 UTC
livecd-tools-16.15-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.15-1.fc16

Comment 9 Fedora Update System 2012-05-03 23:34:43 UTC
livecd-tools-17.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.11-1.fc17

Comment 10 Fedora Update System 2012-05-08 04:32:58 UTC
livecd-tools-17.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.