Bug 786150 - Split CD-I and "extra" stuff to a k3b-extras or k3b-extra-formats subpackage
Split CD-I and "extra" stuff to a k3b-extras or k3b-extra-formats subpackage
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Target-kde
  Show dependency treegraph
 
Reported: 2012-01-31 10:37 EST by Kevin Kofler
Modified: 2016-11-30 19:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-06 11:28:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2012-01-31 10:37:40 EST
Description of problem:
K3b includes these directories:
/usr/share/kde4/apps/k3b/cdi/ – support for CD-I(nteractive). Who burns such a thing?
/usr/share/kde4/apps/k3b/extra/ – the name says it all… (2 canned MPEG files used for the exotic Photo-VCD and Photo-SVCD formats)
These together take about 4 MiB and are mostly already compressed.

I suggest splitting those out into an optional subpackage which would not be included on the live image.

Version-Release number of selected component (if applicable):
k3b-2.0.2-6.fc17

How reproducible:
Always.

Steps to Reproduce:
1. Browse /usr/share/kde4/apps/k3b/ in a file manager.
  
Actual results:
Support for formats hardly anybody uses taking up valuable space.

Expected results:
Support for formats hardly anybody uses not installed by default.

Additional info:
This should help keeping our size image well-sized and hopefully allow us to readd Krusader.
Comment 1 Honza Horak 2012-02-06 11:00:18 EST
I've tried the suggested change and it turned out that "extra" package won't safe so much space - specifically only 652K. I think this is caused by MPEG1 compression of the mpg files, which is compressed better into rpm later. Is 652K worth fixing this bug?
Comment 2 Rex Dieter 2012-02-06 11:28:12 EST
confirmed, the live image savings will likely be comparable to the rpm size differences (similar compression), so I'd have to agree that benefits here aren't sufficient to justify splitting it out. :(

i guess we'll have to explore other possibilities to save kde live image space.

Note You need to log in before you can comment on or make changes to this bug.