Bug 786243 - Subwoofer in ASUS G73 does not work
Subwoofer in ASUS G73 does not work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 14:44 EST by Rudd-O DragonFear
Modified: 2012-09-28 03:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 14:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudd-O DragonFear 2012-01-31 14:44:15 EST
Description of problem:

ASUS G73 has a subwoofer, that depends on some ALSA codec mappings as specified by the diwic source package linked here:

http://rudd-o.com/linux-and-free-software/does-the-subwoofer-in-your-asus-laptop-not-work-under-fedora

As of latest kernel, this workaround does not work anymore.  What should be done is upstream the mappings to the linux kernel.  As I have no idea how to do that,  I defer to better experts than me.

Version-Release number of selected component (if applicable):

kernel-3.2.2-1.fc16.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. Play bass heavy music.
2. Notice subwoofer not working
3. Do not profit
  
Actual results:


Expected results:


Additional info:
Comment 1 Rudd-O DragonFear 2012-01-31 20:21:46 EST
By the way, the problem is with the alsa drivers that come with the kernel, as you can see the diwic package (enhanced version available here: https://launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages ) contains numerous patches for HDA cards.
Comment 2 Dave Jones 2012-02-01 13:21:30 EST
we're not merging alsa snapshots, so unless you can identify the individual patch(es) that fix the problem, you'll have to wait until 3.3 is backported to f16.
Comment 3 Rudd-O DragonFear 2012-02-01 17:20:19 EST
OK, so these alsa snapshots will be upstreamed to 3.3 on Fedora 17, right?  I can wait for that.
Comment 4 Rudd-O DragonFear 2012-02-02 17:49:25 EST
I have upstreamed this bug: https://bugzilla.kernel.org/show_bug.cgi?id=42720
Comment 5 Rudd-O DragonFear 2012-02-03 08:40:46 EST
Takashi Iwai was kind enough to port the bass slave volume fix to his tree, and ping Linus about upstreaming his fix:

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=blobdiff;f=sound/pci/hda/patch_realtek.c;h=6c8ef04c9c49965bb054f9e7d1efcc5862c9ca3f;hp=a8e82be3d2fc4327a429ea0117ca30f66a114a55;hb=28f6c6b4f1c16c74ee6a3a7230685525b679df7d;hpb=b5bcc189401c815988b7dd37611fc56f40c9139d

This bug should be closed nextrelease if F17 is going to have 3.3.
Comment 6 Dave Jones 2012-03-22 12:46:57 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 12:51:37 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 8 Dave Jones 2012-03-22 13:02:16 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 9 Marcel Schaal 2012-03-22 17:55:02 EDT
Hi,

I tried kernel-3.3.0-4.fc16 and the subwoofer didn't work out of the box. So I fired up alsamixer which showed "bass speaker" muted. I increased it's volume and the subwoofer started to work. I rebooted into 3.2.10-3 and saw the same "bass speaker, tried some song and it worked.

So I guess this ain't a kernel problem.
@Rudd: Would you mind to check alsamixer's settings?

Regards
Marcel
Comment 10 Rudd-O DragonFear 2012-03-22 21:10:55 EDT
It is a kernel problem, because the volume pin to output pin wiring for the sub happens in the kernel module.

It has been mostly fixed in kernel 3.3.  Raising and lowering the master volume now raises and lowers the output sound (note, not the visual volume control) of the sub speaker, SO LONG as the bass speaker volume is first manually set to 100.

Now the module needs to set the Bass Speaker volume to 100 by default, as it's pointless to set it to 0 (the current default).
Comment 11 Josh Boyer 2012-09-17 14:32:12 EDT
Closing this out.  If there's further work to do, I would suggest you continue to work with upstream as you have already done.
Comment 12 Rudd-O DragonFear 2012-09-28 03:31:06 EDT
Yeah, this is fixed.  I did end up moving to Ubuntu.

Note You need to log in before you can comment on or make changes to this bug.