Bug 786303 - Cannot boot with full disk encryption and Logitech wireless keyboard
Summary: Cannot boot with full disk encryption and Logitech wireless keyboard
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
(Show other bugs)
Version: 16
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-01 01:23 UTC by Robert Buchholz
Modified: 2012-02-20 12:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-20 12:33:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Buchholz 2012-02-01 01:23:13 UTC
Description of problem:
Since upgrading Fedora 16 from kernel 3.1 to kernel 3.2 (3.2.2-1.fc16.x86_64 specifically), the keyboard is not usable at the boot prompt anymore. It is usable in Grub before and in the console after booting.

The reason seems to be that since Kernel 3.2, the USB device has its own driver to support multiple hid devices from one usb device (hid_logitech_dj) and does not use the regular usbhid anymore:
http://lwn.net/Articles/458418/

Workaround:
In /etc/dracut.conf set
 add_drivers+="hid_logitech_dj"
and then run
 /sbin/dracut -f /boot/initramfs-3.2.2-1.fc16.x86_64.img 3.2.2-1.fc16.x86_64


Version-Release number of selected component (if applicable):
kernel-3.2.2-1.fc16.x86_64
dracut-013-20.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1. Plug in Logitech keyboard with Unifying Receiver
2. Upgrade to Kernel >=3.2
3. Reboot
  
Actual results:
Cannot enter password in initramfs

Expected results:
Keyboard is usable in initramfs

Additional info:

Comment 1 Harald Hoyer 2012-02-20 12:33:10 UTC
workaround for F16:

edit /etc/dracut.conf:

add_drivers+=" hid-logitech-dj "


F17/rawhide dracut version has it hardcoded right now.


Note You need to log in before you can comment on or make changes to this bug.