This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 786374 - kernel 3.2.2 breaks intel centrino wireless
kernel 3.2.2 breaks intel centrino wireless
Status: CLOSED DUPLICATE of bug 785239
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 04:05 EST by Jonathan Underwood
Modified: 2012-02-01 12:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-01 12:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci output (11.48 KB, text/plain)
2012-02-01 11:26 EST, Jonathan Underwood
no flags Details

  None (edit)
Description Jonathan Underwood 2012-02-01 04:05:37 EST
Description of problem:
I have a Samsung netbook with built in wireless:

09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
	Subsystem: Samsung Electronics Co Ltd Device c0a8
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR- INTx-
	Latency: 0, Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 46
	Region 0: I/O ports at 2000 [size=256]
	Region 2: Memory at f050c000 (64-bit, prefetchable) [size=4K]
	Region 4: Memory at f0508000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169


With kernel 3.2.2 wireless associates with an AP just fine, but after a few seconds to a few minutes the connection drops. NetworkManager still thinks the link is up, nothing appears in dmesg, but the link is dead. Restarting NetworkManager.service restarts the connection, but after a few seconds it dies again in the same way. Reverting to kernel 3.1.6-1 fixes the problem.

Version-Release number of selected component (if applicable):
kernel-3.2.2-1.fc16.x86_64

How reproducible:
Everytime
Comment 1 John W. Linville 2012-02-01 11:09:47 EST
That lspci info is for an ethernet card. :-)  Can you attach the full lspci (or 'lspci -n') output?
Comment 2 Jonathan Underwood 2012-02-01 11:26:55 EST
Created attachment 558869 [details]
lspci output
Comment 3 Jonathan Underwood 2012-02-01 11:27:49 EST
Not enough coffee, sorry. It's a:


05:00.0 Network controller: Intel Corporation Centrino Wireless-N 130 (rev 34)

so, iwlwifi and friends.
Comment 4 Jonathan Underwood 2012-02-01 12:22:30 EST
OK, this now looks like a duplicate of BZ 785239, closing as such.

*** This bug has been marked as a duplicate of bug 785239 ***

Note You need to log in before you can comment on or make changes to this bug.