Bug 78659 - ddcprobe (in kudzu package) does not handle ATI Rage
ddcprobe (in kudzu package) does not handle ATI Rage
Status: CLOSED DUPLICATE of bug 107441
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 02:08 EST by Jon Smirl
Modified: 2014-03-16 22:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2002-11-27 02:08:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020922

Description of problem:
ddcprobe (in kudzu package) does not handle ATI Rage family when  
detecting monitors. The card is definitely DDC capable and the XFree
driver for it can successfully detect the DDC.

(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
        compiled for 4.2.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.5
(II) R128(0): VESA BIOS detected
(II) R128(0): VESA VBE Version 2.0
(II) R128(0): VESA VBE Total Mem: 32768 kB
(II) R128(0): VESA VBE OEM: ATI RAGE128
(II) R128(0): VESA VBE OEM Software Rev: 1.0
(II) R128(0): VESA VBE OEM Vendor: ATI Technologies Inc.
(II) R128(0): VESA VBE OEM Product: R128
(II) R128(0): VESA VBE OEM Product Rev: 01.00
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/X11R6/lib/modules/libddc.a
(II) R128(0): VESA VBE DDC supported
(II) R128(0): VESA VBE DDC Level 2
(II) R128(0): VESA VBE DDC transfer in appr. 2 sec.
(II) R128(0): VESA VBE DDC read successfully
(II) R128(0): Manufacturer: VSC  Model: 5547  Serial#: 16843009
(II) R128(0): Year: 2001  Week: 24
(II) R128(0): EDID Version: 1.3
(II) R128(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
(II) R128(0): Sync:  Separate
(II) R128(0): Max H-Image Size [cm]: horiz.: 30  vert.: 23
(II) R128(0): Gamma: 1.80
(II) R128(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) R128(0): First detailed timing is preferred mode
(II) R128(0): redX: 0.595 redY: 0.350   greenX: 0.315 greenY: 0.575
(II) R128(0): blueX: 0.150 blueY: 0.125   whiteX: 0.300 whiteY: 0.320
(II) R128(0): Supported VESA Video Modes:
(II) R128(0): 640x480@60Hz
(II) R128(0): 640x480@72Hz
(II) R128(0): 640x480@75Hz
(II) R128(0): 800x600@56Hz
(II) R128(0): 800x600@60Hz
(II) R128(0): 800x600@72Hz
II) R128(0): 1024x768@60Hz
(II) R128(0): 1024x768@70Hz
(II) R128(0): 1024x768@75Hz
(II) R128(0): Manufacturer's mask: 0
(II) R128(0): Supported additional Video Mode:
(II) R128(0): clock: 65.0 MHz   Image Size:  304 x 228 mm
(II) R128(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1344
h_border: 0
(II) R128(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
(II) R128(0): Serial No: GU12401078
(II) R128(0): Ranges: V min: 50  V max: 75 Hz, H min: 30  H max: 60 kHz,
PixClock max 80 MHz
(II) R128(0): Monitor name: VE150
(==) R128(0): Using gamma correction (1.0, 1.0, 1.0)
(==) R128(0): Write-combining range (0xdc000000,0x2000000)
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
        compiled for 4.2.0, module version = 1.2.0
        ABI class: XFree86 Video Driver, version 0.5
(II) R128(0): I2C bus "DDC" initialized.
(II) R128(0): I2C device "DDC:ddc2" registered.
(II) R128(0): I2C device "DDC:ddc2" removed.
(EE) R128(0): No DFP detected
(WW) R128(0): config file hsync range 31-92kHz not within DDC hsync range 30-60kHz
(WW) R128(0): config file vrefresh range 56-85Hz not within DDC vrefresh range
50-75Hz
(II) R128(0): Monitor0: Using hsync range of 31.00-92.00 kHz
(II) R128(0): Monitor0: Using vrefresh range of 56.00-85.00 Hz
(II) R128(0): Clock range:  12.50 to 400.00 MHz
(II) R128(0): Not using default mode "1024x768" (vrefresh out of range)
(II) R128(0): Not using default mode "512x384" (vrefresh out of range)
(WW) (1024x768,Monitor0) mode clock 94.5MHz exceeds DDC maximum 80MHz
(WW) (1152x864,Monitor0) mode clock 108MHz exceeds DDC maximum 80MHz
(WW) (1280x960,Monitor0) mode clock 108MHz exceeds DDC maximum 80MHz
(WW) (1280x960,Monitor0) mode clock 148.5MHz exceeds DDC maximum 80MHz
(WW) (1280x1024,Monitor0) mode clock 108MHz exceeds DDC maximum 80MHz
(WW) (1280x1024,Monitor0) mode clock 135MHz exceeds DDC maximum 80MHz


Version-Release number of selected component (if applicable): 0.99.69


How reproducible:
Always

Steps to Reproduce:
1. Install ATI Rage 128
2. run ddcprobe

	

Actual Results:  note error return

Expected Results:  Decoded DDC info should have been displayed

Additional info:

There are several posts to newsgroups about this causing install failures for RH
by writing a broken XF86Config file.
Comment 1 Jon Smirl 2002-11-27 15:52:31 EST
After further investigation this is not a problem with the Rage128, it's a
problem with dual video adapter systems. In my system the Rage128 is the primary
video card, a Radeon 9000 is secondary. X runs on the 9000, Rage128 is only used
as a console.

Running ddcprobe from the Rage as a console works. Running ddcprobe from an
xterm on the 9000 doesn't. ddcprobe from the xterms picks of some of the data
from the Rage and then errors out.

The correct behavior from an xterm should be to get the DDC data for the 9000,
not the Rage, since the 9000 is the active console.

This problem manifests itself as the monitor "Probe" button being disabled in
redhat-config-xfree86.

Two possible fixes:
1) fix it in X so that when X is activated, alter the VESA vector to give the
right data for the X display
2) change the way ddcprobe is getting the data and use the implementation in the
X libraries instead of VESA

Isn't 2.5 getting support for multiple active consoles? If so ddcprobe is going
to need to be modified to deal with it.
Comment 2 Jon Smirl 2003-01-06 01:32:28 EST
I ran across this program for resetting secondary
adapters. 
http://www.arava.co.il/matan/svgalib/hypermail/1660.html
Inside of the download you can build vbios.vm86. The
vm86 version worked on my Rage128. The x86emu version
runs, but doesn't reset the adapter.

I had tried hacking this code out of X86 without
success. I also tried moding lrmi. lrmi needs more of
the bios vectors, entry points, etc set up.

There are later versions of x86emu here
ftp://ftp.scitechsoft.com/devel/x86emu but I can get
them to build. 

On a related note, in redhat-config-xfree86 the probe
monitor button is always disabled on the secondary
adapter. This is because redhat-config-xfree86 uses
ddcprobe to do the configing. ddcprobe uses lrmi which
can't handle a secondary adapter.

The code in vbios.vm86 could probably be merged into
ddcprobe/lrmi to make it work. Then it would be easy
to give ddcprobe a reset parameter too.
Comment 3 Bill Nottingham 2005-09-23 16:15:28 EDT

*** This bug has been marked as a duplicate of 107441 ***

Note You need to log in before you can comment on or make changes to this bug.