Bug 78660 - Ctrl-alt-backspace powers system off
Summary: Ctrl-alt-backspace powers system off
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-27 08:38 UTC by Trond Eivind Glomsrød
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-02 12:29:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrød 2002-11-27 08:38:15 UTC
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] SiS630 GUI
Accelerator+3D (rev 31)

When you hit ctrl-alt-backspace to exit X, the system turns off (in a second,
not the controlled shutdown way). The system runs 1024x768, 16 bpp and seems to
work normally other than that.... even accelerated 3D works.

All updates applied.

XFree86-4.2.0-72
kernel-2.4.18-18.8.0

Comment 1 Michael Lee Yohe 2002-11-27 14:37:40 UTC
Is your system entering a suspend/sleep mode?  In other words, if you turn your
system back on - does it pop up back into X?  Or does the system execute as if
it's been powered off?

Does your XFree86.0.log contain anything useful?  Does your /var/log/messages
contain any kernel OOPSes or useful messages?

Comment 2 Trond Eivind Glomsrød 2002-11-27 14:46:10 UTC
No, the system is not just hibernating. Nothing in logs, or I would have written
it. It just shuts off hard and immediately :)

(Hah - I know you love broken hardware. Oh, and before you ask: No binary kernel
modules. Pretty vanilla setup, too...)

Comment 3 Michael Lee Yohe 2002-11-27 15:01:09 UTC
Here's something you can do to isolate it within the driver for your video card.
 Override the video card settings configured for your system to use the basic
SVGA X server.  CTRL+ALT+BKSP to see if it sends your system spiraling into the
abyss.  That'll help Mike figure out where your problem is.

Comment 4 Trond Eivind Glomsrød 2002-12-02 09:45:16 UTC
Tested it last week with the vesa driver - same thing happens.

Comment 5 Mike A. Harris 2002-12-02 11:30:49 UTC
Hi Trond,

Could you attach your config file, and the log from the X session that
conks out, as well as /var/log/messages

Could be DRI related.  I presume you probably tried disabling
DRI already though.  If not, try that to see if it goes away.

Also try noaccel.  If any of those options change anything, we can
try some other things to hopefully narrow narrow it down.

I've added Alan, as he is a big SiS fan.  ;o)

TTYL



Comment 6 Trond Eivind Glomsrød 2002-12-02 11:43:51 UTC
Better SiS than MediaGX... >:->

 I've tried without DRI (obviously one of the first things I tried...), and it
wouldn't have effected VESA anyway. Nothing interesting in any of the logs

Comment 7 Alan Cox 2002-12-02 12:29:10 UTC
ctrl-alt-backspace is a powerdown hotkey on some SiS boards/bios setups. I don't
believe you can change that. I don't know if X lets you change the key combination


Comment 8 Trond Eivind Glomsrød 2002-12-02 13:22:16 UTC
Well, broken BIOSes are hardly the fault of X....

Comment 9 Mike A. Harris 2002-12-02 14:50:56 UTC
Good thing I added Alan.  I've never heard of this SiS issue before so it
could have sent me on a wild goose chase.  ;o)

/me owes Alan a nice pint of ale at OLS 2003 for this one

Trond, there are plans for XFree86 to allow configuration of the various
hotkey sequences that might get into 4.3.0, and might even be in it
already.  If you're up to it, give rawhide X a shot.

If it isn't in currently, you can also rebuild the X server with modified
hotkey manually.  The code is somewhere in the hw/xfree86/common directory
IIRC.  Let me know if you need a hand fiddling with it, and I'll try
to come up with some hack if it isn't currently configurable.

TTYL

Comment 10 Trond Eivind Glomsrød 2002-12-02 15:05:46 UTC
I don't miss ctrl-alt-backspace as much as hate the system turning off in an
unplanned manner, so configurable key combinations aren't going to help that
much I'm afraid.

Thanks, Alan.

Comment 11 Mike A. Harris 2002-12-04 22:40:20 UTC
Understood...

Just thought I'd mention the configurable keys are now in CVS builds, however
I haven't investigated how to configure them.  Just thought I'd let you
know in case it is of some use anyway.

Take care,
TTYL


Note You need to log in before you can comment on or make changes to this bug.