Bug 786605 - kernel-3.2.2-1.fc16.x86_64 regression in iwlwifi driver causes network connection drops
kernel-3.2.2-1.fc16.x86_64 regression in iwlwifi driver causes network connec...
Status: CLOSED DUPLICATE of bug 785239
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 16:51 EST by Gerard Fernandes
Modified: 2012-02-02 14:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 14:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2012-02-01 16:51:45 EST
Description of problem: 
kernel-3.2.2-1.fc16.x86_64 regression in ilwifi driver causes network connection drops. Can only recover by using the RF-KILL switch to disable and re-enable the WiFi link.

Version-Release number of selected component (if applicable):
kernel-3.2.2-1.fc16.x86_64


How reproducible: always
Hardware: Dell Studio 1749
(http://www.smolts.org/client/show/pub_71fa3a21-8057-473c-ab5c-c3d8611e4443)

Steps to Reproduce:
1. Login to shiny new Gnome-3.2 desktop
2. Fire up firefox
3. Check Network Settings/Wireless: note the speed
4. Browse around for a bit. Find your favorite news-site. Read for a while.
5. Repeat (3): Note the speed - will have dropped quite a bit if all you've been doing is reading for a while. When speed drops to the lowest setting (6Mbps), applications "think" there is no active network anymore (although NetworkManager displays an active network connection.

At this point, you can not do anything in Firefox anymore - e.g. try a Google search - it will fail with no network connection error.
  
Actual results: Applications (Firefox/Evolution) think there is no network and time out connecting to sites.


Expected results: Applications attempt to use the network should cause the driver to "wake-up" and boost power so that normal network activities can be carried out.


Additional info: I'm running on 5GHz N with a Netgear WNDR3700 router.

Dropping down to the previous kernel version (3.1.9) makes the wireless behave (no speed drops seen, connection never drops).
Comment 1 Thomas 2012-02-02 05:10:28 EST
I'm experiencing the same problem with Kernel 3.2.2-1.fc16.x86_64. After turning the wireless adapter on/off it behaves 'normal' again, but after a (little) while it happens again.

From time to time I check the rate in the terminal with the command, `iwlist wlan0 rate`. In normal state its 150 Mb/s, it makes small drops to 135 Mb/s, sometimes it recovers, but most of the time it will slowly drop to 1 Mb/s, which causes the connection to fail, whilst the network manager stays its still connected.

As Gerard states, this does not occur when booting in 3.1.9.
Comment 2 Sam Elstob 2012-02-02 08:07:22 EST
I am experiencing the same problem as well.

lspci: Intel Corporation Centrino Wireless-N 1030 (rev 34)
Kernel: 3.2.2-1.fc16.x86_64
router: vmdg280 netgear wireless n cable gateway

System working fine for months until today.  No change to hardware.  Kernel was upgraded by yum on Jan 30th.

First noticed the problem today when working from home.  Wireless in the office which is b/g worked fine.

Additional troubleshooting info:

1. Reloading the driver fixes it temporarily

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

2. There appear to be lots of these messages in the syslog compared to previous weeks "iwlwifi 0000:01:00.0: Tx aggregation enabled on ra = a0:21:b7:5b:9f:b2 tid = 0"

[sam@deben modprobe.d]$ sudo grep -c 'Tx aggregation enabled' /var/log/messages*
/var/log/messages:348
/var/log/messages-20120109:21
/var/log/messages-20120115:13
/var/log/messages-20120122:34
/var/log/messages-20120130:52

3. iwconfig shows lots of excessive retries

wlan0     IEEE 802.11bgn  ESSID:"thesams"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: A0:21:B7:5B:9F:B2   
          Bit Rate=150 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=36/70  Signal level=-74 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:5509  Invalid misc:53   Missed beacon:0
Comment 3 John W. Linville 2012-02-02 14:02:50 EST

*** This bug has been marked as a duplicate of bug 785239 ***

Note You need to log in before you can comment on or make changes to this bug.