Bug 7867 - Problem getting my printer and APTI Zip drive setup.
Problem getting my printer and APTI Zip drive setup.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-17 09:22 EST by jshivley
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-17 09:36:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jshivley 1999-12-17 09:22:46 EST
I have a 722C HP printer and a APTI IDE Zip drive and I don't think that
my parralel port and my SCSI emulation is setup correctly or at least I
have tried what every one has suggested and I still can't get my printer
or Zip drive working.  I have put these two together because I think the
problems are related.  I have also tried a 560C HP, which you support(same
result).
Here is what I have done: I have 5 Items below:  Thanks in advance for
your help.

1) I have configured my Kernel this way.  Here is the contents of
my /etc/conf.modules:

alias scsi_hostadapter ppa
alias parport_lowlevel paraport_pc

alias sound sb
pre-install sound /sbin/insmod sound dmabuf=1
options opl3 io=0x388
alias midi awe_wave
post-install awe_wave /bin/sfxload /etc/midi/GU11-ROM.SF2
options sb dma16=5 io=0x220 mpu_io=0x330 dma=1 irq=5

2)Here is the results of my boot up using this kernel:

Linux version 2.2.12-20 (root@porky.devel.redhat.com) (gcc version egcs-
2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Mon Sep 27 10:40:35 EDT
1999
Detected 350803275 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 349.80 BogoMIPS
Memory: 127608k/131008k available (1008k kernel code, 412k reserved, 1636k
data, 64k init)
DENTRY hash table entries: 262144 (order: 9, 2097152 bytes)
Buffer-cache hash table entries: 131072 (order: 7, 524288 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium II (Deschutes) stepping 02
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xf0720
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.9)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
PIIX4: IDE controller on PCI bus 00 dev 21
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:pio
hda: WDC AC36400L, ATA DISK drive
hdb: WDC AC21000H, ATA DISK drive
hdc: Creative CD-ROM CD4832E, ATAPI CDROM drive
hdd: IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: WDC AC36400L, 6149MB w/256kB Cache, CHS=784/255/63
hdb: WDC AC21000H, 1033MB w/128kB Cache, CHS=525/64/63
hdc: ATAPI 44X CD-ROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.56
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :   779.907 MB/sec
   p5_mmx    :   818.769 MB/sec
   8regs     :   602.361 MB/sec
   32regs    :   337.947 MB/sec
using fastest function: p5_mmx (818.769 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: hda1
 hdb: hdb1 hdb2 < hdb5 hdb6 >
RAMDISK: Compressed image found at block 0
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem).
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 64k freed
Adding Swap: 66488k swap-space (priority -1)
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
SB 4.16 detected OK (220)
<SoundBlaster EMU8000 (RAM512k)>
VFS: Disk change detected on device ide1(22,0)

3) Here is what it says when I try using printools:

/dev/lp0 not detected
/dev/lp1 not detected
/dev/lp2 not detected

I'm using the pbm2ppa with my 722C HP and I know you don't support this
but I can't even get printools to detect a 560C HP printer you do
support.  Should it at least detect a printer at this point?

4) here is what is says when I use the command /sbin/lsmod ppa:

Module                  Size  Used by
nls_cp437               3548   1  (autoclean)
msdos                   5276   1  (autoclean)
fat                    30464   1  (autoclean) [msdos]
parport_probe           2980   0  (autoclean) (unused)
parport                 7124   0  [parport_probe]
awe_wave              157804   0
sb                     33620   0
uart401                 5968   0  [sb]
sound                  57240   0  [awe_wave sb uart401]
soundlow                 300   0  [sound]
soundcore               2372   7  [sb sound]

5) Here is what is says when I use the command /sbin/modprobe ppa

/lib/modules/2.2.12-20/scsi/ppa.o: init_module: Device or resource busy
paraport: Device or resource busy
Comment 1 Bernhard Rosenkraenzer 1999-12-17 09:36:59 EST
It's not a bug, it's a typo and a misunderstanding.

It's
	alias parport_lowlevel parport_pc
not
	alias parport_lowlevel paraport_pc

As for the ZIP drive, ATAPI zip drives don't need ppa. ppa is for parallel port
zip drives. Looking at your kernel output, your zip drive is recognized
correctly, and is available as /dev/hdd.
The problem is probably iomega's weird partitioning. If you want to mount a zip
disk that was formatted using their tool in DOS or Windoze, it's /dev/hdd4
instead of /dev/hdd1, for whatever reason.

Note You need to log in before you can comment on or make changes to this bug.