Bug 786734 - gedit-beesu-plugin doesn't work
Summary: gedit-beesu-plugin doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: beesu
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-02 09:21 UTC by paul59584
Modified: 2012-04-24 14:58 UTC (History)
2 users (show)

Fixed In Version: beesu-2.7-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-10 02:03:13 UTC
Type: ---


Attachments (Terms of Use)

Description paul59584 2012-02-02 09:21:30 UTC
Description of problem:

gedit-beesu-plugin installs with yum but doesn't show up as a plugin in gedit. Files are installed in /usr/lib64/gedit-2/plugins whereas all other gedit plugins are in /usr/lib64/gedit/plugins.

Version-Release number of selected component (if applicable):

Name        : gedit-beesu-plugin
Arch        : x86_64
Version     : 0.4
Release     : 4.fc15


How reproducible:

always

Steps to Reproduce:

1. install gedit-beesu-plugin
2. try to use it
3.
  
Actual results:

plugin doesn't show in gedit

Expected results:

plugin should show in gedit and be able to be used

Comment 1 Fedora Update System 2012-02-10 22:07:13 UTC
beesu-2.7-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/beesu-2.7-6.fc15

Comment 2 Fedora Update System 2012-02-10 22:07:24 UTC
beesu-2.7-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/beesu-2.7-6.fc16

Comment 3 paul59584 2012-02-11 00:46:05 UTC
Hi

Just tried these updates, plugin now shows up in plugin list of gedit but when activated fails to load with following output in terminal.

$ gedit
Traceback (most recent call last):
  File "/usr/lib64/gedit/plugins/beesu/__init__.py", line 1, in <module>
    from beesu import beesuPlugin
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 16, in <module>
    import gedit
ImportError: No module named gedit

(gedit:3051): libpeas-WARNING **: Error loading plugin 'beesu'



Thanks

Comment 4 paul59584 2012-02-11 01:08:16 UTC
maybe should be in another bug report but this has reminded me that to get the "Open Nautilus Here" from nautilus-beesu-manager script to work you need to remove the --browser option from /usr/libexec/nautilus-beesu-manager/scripts/Open\ Nautilus\ Here.
i.e. change
beesu - nautilus --browser "$dir"
to
beesu - nautilus "$dir"

 
nautilus doesn't open with --browser option anymore

$ nautilus --browser
Could not parse arguments: Unknown option --browser

Comment 5 Fedora Update System 2012-02-11 21:54:08 UTC
Package beesu-2.7-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing beesu-2.7-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1551/beesu-2.7-6.fc16
then log in and leave karma (feedback).

Comment 6 paul59584 2012-02-11 23:55:09 UTC
Package beesu-2.7-6.fc16 is what I was referring to in comment 3. I downloaded it from link in comment 2 and used yum localupdate to install it.
output from "yum info beesu" is

Installed Packages
Name        : beesu
Arch        : x86_64
Version     : 2.7
Release     : 6.fc16
Size        : 29 k
Repo        : installed
From repo   : /beesu-2.7-6.fc16.x86_64
Summary     : Graphical wrapper for su
URL         : http://www.honeybeenet.altervista.org
License     : GPLv2+
Description : Beesu is a wrapper around su and works with consolehelper under
            : Fedora to let you have a graphic interface like gksu.

also have packages
gedit-beesu-plugin-0.4-6.fc16.x86_64
beesu-debuginfo-2.7-6.fc16.x86_64
nautilus-beesu-manager.noarch 0:1.7-4.fc15
installed.

still have same problem as in comment 3

also, should I start another bug for issue in comment 4?

Comment 7 Tom "spot" Callaway 2012-02-13 15:17:35 UTC
No, I'll tackle them both here.

Comment 8 Fedora Update System 2012-03-01 22:33:56 UTC
beesu-2.7-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/beesu-2.7-7.fc17

Comment 9 paul59584 2012-03-02 03:49:26 UTC
excellent, have installed

  beesu.x86_64 0:2.7-7.fc17                                                     
  gedit-beesu-plugin.x86_64 0:0.4-7.fc17                                        
  nautilus-beesu-manager.noarch 0:1.7-7.fc17  

on f16 x86_64 system and all seems to be working well

thank-you

Comment 10 Fedora Update System 2012-03-05 20:59:59 UTC
Package beesu-2.7-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing beesu-2.7-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2955/beesu-2.7-7.fc17
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2012-03-10 02:03:13 UTC
beesu-2.7-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-04-24 14:58:17 UTC
beesu-2.7-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-04-24 14:58:29 UTC
beesu-2.7-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.