Bug 786735 - totem: Correct nodeid of token when we retransmit it
Summary: totem: Correct nodeid of token when we retransmit it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.3
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-02 09:32 UTC by Jan Friesse
Modified: 2013-02-21 07:49 UTC (History)
3 users (show)

Fixed In Version: corosync-1.4.1-8.el6
Doc Type: Bug Fix
Doc Text:
Cause Corosync entered recovery state. Consequence Incorrect nodeid was sent in recovery messages. This is NOT visible by users, but it may make harder to debug problems in source code (by developers or SEG) Fix Set correct nodeid. Result Nodeid is correctly set.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:49:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch from flatiron branch in git (1.62 KB, patch)
2012-02-02 09:32 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jan Friesse 2012-02-02 09:32:01 UTC
Created attachment 559016 [details]
Proposed patch from flatiron branch in git

Description of problem:
Although incorrect nodeid will not affect program's logic, but it will
make us confused when we add some logs to record the transmission path of
token in debug mode.

Version-Release number of selected component (if applicable):
flatiron

How reproducible:
100%

Steps to Reproduce:
1. Debug nodeid
  
Actual results:
Incorrect nodeid

Expected results:
Correct nodeid

Additional info:
This doesn't affect customers. It "can" be helpful for GSS and/or developers. Doesn't need to be QA, so sanity only tests are recommended.

Comment 3 Jan Friesse 2012-08-06 10:08:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Corosync entered recovery state.

Consequence
Incorrect nodeid was sent in recovery messages. This is NOT visible by users, but it may make harder to debug problems in source code (by developers or SEG)

Fix
Set correct nodeid.

Result
Nodeid is correctly set.

Comment 7 errata-xmlrpc 2013-02-21 07:49:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.