Bug 786737 - Bug when corosync receive JoinMSG in OPERATIONAL state
Summary: Bug when corosync receive JoinMSG in OPERATIONAL state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.3
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-02 09:36 UTC by Jan Friesse
Modified: 2013-02-21 07:50 UTC (History)
3 users (show)

Fixed In Version: corosync-1.4.1-8.el6
Doc Type: Bug Fix
Doc Text:
Cause Node entering GATHER state Consequence Node spend more time in GATHER state then needed. Fix Nodes in OPERATIONAL state will enter GATHER state when it receive JoinMSG. Result All nodes enter GATHER state so nodes previously in GATHER state don't need to wait for token loss.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:50:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch from flatiron git branch (1.76 KB, patch)
2012-02-02 09:36 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jan Friesse 2012-02-02 09:36:02 UTC
Created attachment 559018 [details]
Proposed patch from flatiron git branch

Description of problem:
Accordig the totem protocal, nodes should enter GATHER state when it
receive JoinMSG in OPERATIONAL state. If we discard it in OPERATIONAL
state, the nodes sending this JoinMSG could not receive the response
untill other nodes reach token lost timeout.

This bug will cause nodes having entered GATHER state spend more time to
rejoin the ring, and then it will make nodes reach token expired timeout
more easily.

Version-Release number of selected component (if applicable):
flatiron

How reproducible:
In description, very ard

Steps to Reproduce:
1. In description
  
Additional info:
Very hard (almost impossible) to objectively reproduce. Recomended sanity only testing.

Comment 4 Jan Friesse 2012-08-06 10:14:32 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Node entering GATHER state

Consequence
Node spend more time in GATHER state then needed.
 
Fix
Nodes in OPERATIONAL state will enter GATHER state when it
receive JoinMSG.

Result
All nodes enter GATHER state so nodes previously in GATHER state don't need to wait for token loss.

Comment 8 errata-xmlrpc 2013-02-21 07:50:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.