Bug 78674 - Installer reports an unrecoverable error while installing a package and offers to reboot system.
Installer reports an unrecoverable error while installing a package and offer...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 10:40 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 01:57:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-27 10:40:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
During a fresh Linux install (done on two separate systems) the installer
consistently reports an unrecoverable error that may be due to limited disk
space or hardware. Eac system has different processor, speed, memory and disk
capacities, but the error message is the same. Each system consistenly fails at
a specific package install, but the systems are failing on different packages.
One system fails on 'balsa' install, the other on the xscreensaver install (both
on CD 2). No errors are encountered if the copy of Red Hat Linux version 7.1 is
installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Press 'Enter' key when initial install screen is displayed.
2. Have tried workstation, server, everything package installs.
3. Have tried allowing install to partition hard drive and have tried disk
druid, makes no difference in the outcome.
4. Execute the install process.
	

Actual Results:  Everything seems to proceed properly. The hard drive is
partioned and formatted for ext3 file journaling. I had it do bad block
checking. Preparation for install proceeds normally. Package installation begins
and proceed normally for the first CD. The install program ejects CD 1 and asks
that CD 2 be inserted. After inserting CD 2 and clicking 'OK' to resume, install
seems to resume installation with the 'DSSSL' package. After installing twenty
or so packages the install program produces a dialog box at center screen that
indicates there has been an unrecoverable error during the installation of
'x-screensaver...' and offers to reboot when the button in the dialog box is
clicked.


Expected Results:  The installation should have proceeded through the
installation of packages on CD 2 and CD 3.  I originally thought that this might
be a media problem, however I had successfully installed this CD-ROM set on an
HP laptop, several times.


Additional info:

Computer #1 Celeron, 633 MHz, 128 Meg Ram, 40 Gig HD, 32X Toshiba CD-ROM
Computer #2 Pentium-II, 450 MHz, 512 Meg RAM, 20 Gig HD, Toshiba DVD/CD-ROM

Installation of previous version 7.1 distribution installs without incident on
both of these computers.
Comment 1 Michael Fulbright 2002-12-03 12:35:39 EST
If you look on VC4 (hit cntl-alt-F4) when the error occurs, see if there are any
read errors listed by the kernel.
Comment 2 Need Real Name 2002-12-11 16:05:23 EST
On one of the systems I replaced the 20 Gig hard drive with a new 40 Gig drive.
Instead of sharing the CD-ROM and hard drive both on the primary IDE port, I put
the hard drive on the primary IDE port and the CD-ROM drive on the secondary.  I
have installed the Linux 7.3 twice on this system without any failures.

I have not tried this with the other system, which installed Version 7.1
successfully, yet.
Comment 3 Need Real Name 2002-12-15 23:38:21 EST
I had time to work on the other computer that wasn'tinstalling Version 7.3. It
turns out that the card providing the upper 256 Meg of the machine's 512 Meg of
RAM was intermittent. I noticed that the post reported 310 Meg during a boot.
After pulling the card and running with 256 Meg the install ran without a hitch.

Thanks for your time and assistance.
Comment 4 Jeremy Katz 2003-01-10 01:57:18 EST
Great, glad that you tracked it down.

Note You need to log in before you can comment on or make changes to this bug.