Bug 78680 - "Open with" option should be available all the time for all files
"Open with" option should be available all the time for all files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
: MoveUpstream
Depends On:
Blocks: GnomeUpstream
  Show dependency treegraph
 
Reported: 2002-11-27 11:19 EST by Michael Lee Yohe
Modified: 2015-01-07 19:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-09 09:51:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2002-11-27 11:19:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Nautilus's "Open With" feature is almost like SHIFT+<right clicking> a file in
Windows Explorer.  However, Nautilus's "Open With" feature is handled
"automagically", giving the user the ability to configure what type of viewer to
assign to that particular type of file _if and only if_ the "Open With" menu
subsection is available to the user.

So, something as simple as a C source file which I wish to open up with Anjuta
cannot be done because Nautilus already thinks it knows how I wish to have the
file opened.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select a file that Nautilus does not recognize.
2. Right click on the file and find the "Open With" option.
3. Now, select a different file that Nautilus _does_ recognize (like a C source
file).
4. Right click on the file.
	

Actual Results:  "Open With" option is disabled because Nautilus thinks it
understands how to handle the file.

Expected Results:  "Open With" option should always be available.

Additional info:

$ rpm -q nautilus
nautilus-2.0.6-6
Comment 1 Havoc Pennington 2002-12-16 13:21:38 EST
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.
Comment 2 Leonard den Ottolander 2004-03-09 09:51:08 EST
This is fixed in Fedora Core 1.

Closing CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.