This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 786810 - EIO when the file is deleted while setting ACL
EIO when the file is deleted while setting ACL
Status: CLOSED DUPLICATE of bug 788998
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 08:07 EST by Anush Shetty
Modified: 2013-12-08 20:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-17 03:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-02-02 08:07:12 EST
Description of problem: While setting an ACL on the file, the file was deleted. After than any operation on the mount point returned EIO. All the operations were from the FUSE mount.


Version-Release number of selected component (if applicable): 3.3.0qa20



Steps to Reproduce:
1. Set a ACL entry on a file in a loop
2. Delete the file
3. Access the mount point after deleting the file.
  
Actual results:
# touch /falcon/mnt/dot
touch: cannot touch `/falcon/mnt/dot': Input/output error

Additional info:

Server log-
[2012-02-02 18:28:35.136980] E [posix.c:933:posix_mkdir] 0-test-posix: setting xattrs on /falcon/d1/.glusterfs/00/00/00000000-0000-0000-0000-000000000001/hello failed (Operation not supported)
[2012-02-02 18:29:42.869855] E [posix.c:1678:posix_create] 0-test-posix: setting xattrs on /falcon/d1/.glusterfs/00/00/00000000-0000-0000-0000-000000000001/hello/dot failed (Operation not supported)
[2012-02-02 18:29:42.897854] I [server3_1-fops.c:774:server_getxattr_cbk] 0-test-server: 428: GETXATTR /hello/dot (system.posix_acl_access) ==> -1 (No data available)
[2012-02-02 18:29:46.802567] E [posix.c:1678:posix_create] 0-test-posix: setting xattrs on /falcon/d1/.glusterfs/00/00/00000000-0000-0000-0000-000000000001/hello/dot failed (Operation not supported)
[2012-02-02 18:29:46.918125] I [server3_1-fops.c:774:server_getxattr_cbk] 0-test-server: 1008: GETXATTR /hello/dot (system.posix_acl_access) ==> -1 (No data available)
[2012-02-02 18:30:04.120990] W [inode.c:866:inode_lookup] (-->/usr/local/lib/glusterfs/3git/xlator/features/marker.so(marker_lookup_cbk+0x1f5) [0x7f0e2e8eb849] (-->/usr/local/lib/glusterfs/3git/xlator/debug/io-stats.so(io_stats_lookup_cbk+0x256) [0x7f0e2e6c82e8] (-->/usr/local/lib/glusterfs/3git/xlator/protocol/server.so(server_lookup_cbk+0x6bd) [0x7f0e2e49c5f9]))) 0-test-server: inode not found
[2012-02-02 18:30:04.154839] I [server3_1-fops.c:774:server_getxattr_cbk] 0-test-server: 3017: GETXATTR /hello/dot (system.posix_acl_access) ==> -1 (No data available)


Client log-

h: (null)
[2012-02-02 18:29:46.918202] W [client3_1-fops.c:899:client3_1_getxattr_cbk] 0-test-client-0: remote operation failed: No data available. Path: (null)
[2012-02-02 18:30:04.121234] W [inode.c:866:inode_lookup] (-->/usr/local/lib/glusterfs/3git/xlator/system/posix-acl.so(posix_acl_lookup_cbk+0x37b) [0x7f4a5df728ce] (-->/usr/local/lib/glusterfs/3git/xlator/mount/fuse.so(+0x9110) [0x7f4a60f66110] (-->/usr/local/lib/glusterfs/3git/xlator/mount/fuse.so(+0x8bba) [0x7f4a60f65bba]))) 0-fuse: inode not found
[2012-02-02 18:30:04.154926] W [client3_1-fops.c:899:client3_1_getxattr_cbk] 0-test-client-0: remote operation failed: No data available. Path: (null)
Comment 1 shishir gowda 2012-02-17 03:49:03 EST
This seems to be a dup of bug 788998.
After the fix, the bug is not reproducable.
Please reopen the bug if the behaviour is seen again

*** This bug has been marked as a duplicate of bug 788998 ***

Note You need to log in before you can comment on or make changes to this bug.