Bug 786836 - Spyder 2.1.6 requires pyflakes 0.5.0+ which is not available in Fedora 16
Summary: Spyder 2.1.6 requires pyflakes 0.5.0+ which is not available in Fedora 16
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spyder (Show other bugs)
(Show other bugs)
Version: 16
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Novacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-02 14:37 UTC by Kamil Páral
Modified: 2016-12-01 00:30 UTC (History)
4 users (show)

Fixed In Version: spyder-2.1.6-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-25 08:41:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kamil Páral 2012-02-02 14:37:21 UTC
Description of problem:
Spyder was recently updated to 2.1.6 in F16. However for its code analysis to work, it requires pyflakes 0.5.0+. Currently there is pyflakes-0.4.0-5.fc16.noarch in F16. This causes Spyder to lose one of its greatest benefits - real-time code analysis.

Please make sure Spyder dependencies (even though they are not hard-coded) have sufficient version for Spyder to work optimally. Upgrade pyflakes to version 0.5.0+ in F16.

Version-Release number of selected component (if applicable):
spyder-2.1.6-1.fc16.noarch
pyflakes-0.4.0-5.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1. Open Spyder preferences -> Editor -> Code introspection and see "Code analysis" is grayed out because of insufficient pyflakes version

Comment 1 Radek Novacek 2012-02-03 07:30:40 UTC
Pyflakes maintainer, would it be possible to update pyflakes to 0.5.0+ in Fedora 16? Or are there any dependencies that are not compatible with it?

Comment 2 Fedora Update System 2012-02-05 10:18:11 UTC
pyflakes-0.5.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pyflakes-0.5.0-3.fc16

Comment 3 Ville Skyttä 2012-02-05 10:28:37 UTC
pyflakes update posted, reassigning back to spyder for making the pyflakes dependency versioned (an updated build should probably be added to the mentioned pyflakes bodhi update).

Comment 4 Radek Novacek 2012-02-06 07:50:42 UTC
spyder has been rebuild:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3765070

Can you add the build to the update? Thank you.

Comment 5 Fedora Update System 2012-02-07 07:48:10 UTC
Package spyder-2.1.6-2.fc16, pyflakes-0.5.0-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spyder-2.1.6-2.fc16 pyflakes-0.5.0-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1344/spyder-2.1.6-2.fc16,pyflakes-0.5.0-3.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-02-25 08:41:19 UTC
spyder-2.1.6-2.fc16, pyflakes-0.5.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.