Bug 786867 - [abrt] python-docutils-0.8.1-2.fc16: nodes.py:331:__new__:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
[abrt] python-docutils-0.8.1-2.fc16: nodes.py:331:__new__:UnicodeDecodeError:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-docutils (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
abrt_hash:3e416de081eff1adeab0b5d2ae7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 10:49 EST by Dave Piché
Modified: 2012-08-09 19:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (4.16 KB, text/plain)
2012-02-02 10:49 EST, Dave Piché
no flags Details

  None (edit)
Description Dave Piché 2012-02-02 10:49:46 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/rst2html --traceback --stylesheet-path=standard.css guitar_tuner.rst
executable:     /usr/bin/rst2html
kernel:         3.2.2-1.fc16.i686
reason:         nodes.py:331:__new__:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
time:           jeu 02 fév 2012 10:31:17 EST
uid:            500
username:       dpiche

backtrace:      Text file, 4262 bytes

comment:
:I tried to render the HTML version of my reStructuredText document that contains the following substitution
:definition: .. |date| date:: %d %B %Y. The language of my system (as returned by the command "locale") is
:"fr_CA.utf8". The date substitution is expanded as "2 février 2012" and Docutils doesn't seems to like
:the character 'é'. In January, I ran the same command with no problem because the date substitution was
:expanded as "31 janvier 2012" which contains only ASCII characters. My document is UTF-8 encoded and contains
:many Unicode characters but only the "date::" dicrective seems to not handle them.
Comment 1 Dave Piché 2012-02-02 10:49:49 EST
Created attachment 559076 [details]
File: backtrace
Comment 2 Dave Piché 2012-02-02 10:59:13 EST
Is it preferable for you that I report this kind of bug upstream (to Docutils in this case)?
Comment 3 Toshio Ernie Kuratomi 2012-02-03 14:21:59 EST
It's fine to report here but -- if you can report upstream in addition, that would be awesome.  I don't always have time to look at coding a fix for a problem immediately but if upstream generates a patch, I can add it to our package pretty easily.
Comment 4 Fedora Update System 2012-07-21 00:45:42 EDT
python-docutils-0.8.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-docutils-0.8.1-3.fc16
Comment 5 Fedora Update System 2012-07-21 00:45:56 EDT
python-docutils-0.8.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-docutils-0.8.1-3.fc17
Comment 6 Toshio Ernie Kuratomi 2012-07-21 00:46:22 EDT
Sorry this dropped off my radar.  This update should fix the issue.  Also submitted the patch upstream.
Comment 7 Fedora Update System 2012-07-21 18:49:35 EDT
Package python-docutils-0.8.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-docutils-0.8.1-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10954/python-docutils-0.8.1-3.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-09 18:54:17 EDT
python-docutils-0.8.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-08-09 19:07:08 EDT
python-docutils-0.8.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.