Bug 78688 - Bug number auto-hyperlinking is too simple
Bug number auto-hyperlinking is too simple
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 12:05 EST by Michael Lee Yohe
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 00:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2002-11-27 12:05:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Red Hat's Bugzilla seems to only recognize one style of an embedded bug numbers
for auto-hyperlinking.  While many people specify "Bug <number>", there are
quite a few (including Red Hat employees) which specify an alternative format
that is not recognized as an embedded Bug Number.

See "Expected Results" for examples.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Browse the bugs in Red Hat's Bugzilla.
2. Browse the bugs in Mozilla's Bugzilla.
	

Actual Results:  Red Hat's Bugzilla only recognizes "Bug <number>" format.

Expected Results:  Red Hat's Bugzilla should recognize quite a few formats
(through simple regex additions):

Bug <number>
Bug #<number>
Bug<number>
Bug#<number>
Bugs <number>, <number>
Bugs #<number>, #<number>
Bug ID <number>
Bug ID #<number>
et. al.

Additional info:
Comment 1 David Lawrence 2002-11-27 13:08:30 EST
Let's see:

Bug 78688
Bug #78688
Bug78688
Bug#78688
Bugs 78688, 34222
Bugs #78688, #34222
Bug ID 78688
Bug ID #78688
Comment 2 David Lawrence 2002-11-27 13:09:47 EST
The new bugzilla system also does hyperlinking to the same extent so I will need
to pass this change upstream to the core developers.
Comment 3 Michael Lee Yohe 2002-12-13 17:23:46 EST
Well, the "new" 2.17.1 release (from 2.8 ... very interesting) seems to capture
more auto-linking than the previous Bugzilla.  But I don't understand why "Bug
ID <number>" is captured but "Bug ID #<number>" is not.  Since I have not delved
into the source code of Bugzilla - can't you add templates for the auto-linking?

Bug match = Bug, Bug #, Bugs, Bugs #, Bug ID, Bug ID #
Buglist match = #,+# (or something horked up like that).

**shrug**
Comment 4 Aleksey Nogin 2002-12-14 16:07:34 EST
Buglist:
bugs 123 and 456
bugs 123, 456 and 789
Comment 5 David Lawrence 2006-04-08 13:42:38 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 6 Aleksey Nogin 2006-04-08 14:47:55 EDT
Still there (see comment #2 and comment #4).
Comment 7 David Lawrence 2006-04-11 00:15:16 EDT
I have updated the section of code responsible for linking to the latest from
upstream BZ which should help a little. Any other linking misses should be filed
in a bug report at http://bugzilla.mozilla.org.

Note You need to log in before you can comment on or make changes to this bug.