Bug 786937 - kernel 3.3.0 requires a new (or renamed) bnx2 firmware file
kernel 3.3.0 requires a new (or renamed) bnx2 firmware file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 12:29 EST by Andy Grimm
Modified: 2016-11-07 22:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-08 10:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2012-02-02 12:29:36 EST
Description of problem:
A bnx2 network card - id 14e4:163b (rev 20) - causes the following error on boot:

kernel: [   16.272402] bnx2: Can't load firmware file "bnx2/bnx2-mips-09-6.2.1b.fw"


Version-Release number of selected component (if applicable):
kernel-3.3.0-0.rc1.git6.1.fc17.x86_64
linux-firmware-20110731-3.fc17.noarch

How reproducible:
Always

Steps to Reproduce:
1. install kernel-3.3.0-0.rc1.git6.1.fc17.x86_64
2. reboot the system
  
Actual results:
The error mentioned above, and no usable network link.

Expected results:
Successful firmware loading, network link

Additional Info:
Copying bnx2/bnx2-mips-09-6.2.1a.fw to bnx2/bnx2-mips-09-6.2.1b.fw was a sufficient workaround.

The problem was mentioned on the kernel netdev list here:
http://marc.info/?l=linux-netdev&m=132616185703573&w=2

However, I did not see 6.2.1b in the linux-firmware git tree, only 6.2.1 and 6.2.1a
Comment 1 Josh Boyer 2012-02-02 12:37:21 EST
There's a similar report for bnx2x as well that is hitting F16 because the compat-wireless stuff brings the 3.3-rc1 drivers back to the F16 3.2 kernel.

David, I'll look at updating linux-firmware in Fedora if I don't hear from you by Monday.
Comment 2 Josh Boyer 2012-02-06 13:07:18 EST
Andy, can you see if this build works for you:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3766412
Comment 3 Kevin Fenzi 2012-02-07 17:06:08 EST
Works here on a machine that needs it.
Comment 4 Josh Boyer 2012-02-07 19:33:45 EST
(In reply to comment #3)
> Works here on a machine that needs it.

Thanks Kevin.  I think I'll commit and submit this as an update.
Comment 5 Josh Boyer 2012-02-08 10:19:10 EST
This should be fixed in today's rawhide.

Note You need to log in before you can comment on or make changes to this bug.