Bug 786966 - bluez 4.97 introduced a regression
bluez 4.97 introduced a regression
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 13:59 EST by Alex Lancaster
Modified: 2012-08-07 08:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 08:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixes compilation error in bluetooth headers (1.44 KB, patch)
2012-02-02 13:59 EST, Alex Lancaster
no flags Details | Diff

  None (edit)
Description Alex Lancaster 2012-02-02 13:59:04 EST
Created attachment 559115 [details]
Fixes compilation error in bluetooth headers

bluez 4.97 introduced a regression that causes some apps not to compile properly (e.g. xbmc, see: http://trac.xbmc.org/ticket/12441 ).  Other distros have patched this to fix the compilation errors, e.g. this is the version of the Ubuntu package:

https://launchpad.net/~wsnipex/+archive/xbmc-xvba-testing/+sourcepub/2205552/+listing-archive-extra

I have extracted the patch in that package and I'm attaching it to this bug.
Comment 1 Alex Lancaster 2012-02-25 13:48:36 EST
Ping?  Is this fixed in the latest 4.98?
Comment 2 Alex Lancaster 2012-02-26 19:19:52 EST
(In reply to comment #1)
> Ping?  Is this fixed in the latest 4.98?

To answer my own question, apparently not, rawhide now has bluez 4.98, but builds still fail:

http://buildsys.rpmfusion.org/logs/fedora-development-rpmfusion_free/12041-xbmc-11.0-0.6.Eden_beta2.fc18/x86_64/build.log


Apparently the 4.98-r2 build on gentoo does allow this to work:

http://trac.xbmc.org/ticket/12441#comment:13

can the maintainer look at the gentoo package to see if fix can be ported here?

Cc'ing Peter Robinson who apparently last build the bluez package, but isn't listed as maintainer.
Comment 3 Peter Robinson 2012-02-26 19:31:30 EST
> Cc'ing Peter Robinson who apparently last build the bluez package, but isn't
> listed as maintainer.

I'm not the maintainer. It was blocking me for ARM building so I fixed the bug I was running into. That said there's a bug/regression in g++ 4.7.0 that's going to necessitate a mass rebuild of all c++ programs on rawhide/F-17. Do you know if that might be the cause of the build failure and not a regression in bluez. I believe that will happen early next week.
Comment 4 Alex Lancaster 2012-02-27 11:21:22 EST
(In reply to comment #3)
> > Cc'ing Peter Robinson who apparently last build the bluez package, but isn't
> > listed as maintainer.
> 
> I'm not the maintainer. 

Right, but since you last built it, I figured you might have some insight as to it's current state, since the main maintainer hasn't responded in over 3 weeks.

> It was blocking me for ARM building so I fixed the bug
> I was running into. That said there's a bug/regression in g++ 4.7.0 that's
> going to necessitate a mass rebuild of all c++ programs on rawhide/F-17. Do you
> know if that might be the cause of the build failure and not a regression in
> bluez. I believe that will happen early next week

No it's definitely a regression, see: http://trac.xbmc.org/ticket/12441#comment:5

It's a problem with the API headers (see also attached patch).
Comment 5 Peter Robinson 2012-08-07 08:27:45 EDT
This has been resolved. There was an issue with gcc, a work around was initially applied but now been dropped as it's no longer required.

Note You need to log in before you can comment on or make changes to this bug.