This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 787017 - shutting down agent sometimes causes a JVM crash/core dump
shutting down agent sometimes causes a JVM crash/core dump
Status: CLOSED DUPLICATE of bug 824850
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.2
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 17:14 EST by John Mazzitelli
Modified: 2014-03-04 15:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 16:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
hs_err dump file (44.80 KB, text/plain)
2012-02-02 17:17 EST, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2012-02-02 17:14:22 EST
Periodically (lately on my machine, its about every 3 time or so), when you exit the agent, the JVM crashes, core dumping, and causes the console window to have its stdin hosed.

I think its because the native augeas layer is causing the crash.

We need to a way to turn off the native augeas layer, just like we do with --nonative.

We should have a global plugin container setting "disableNative" so any PC manager can look to see if it should be disabling required native libraries.
Comment 1 John Mazzitelli 2012-02-02 17:16:27 EST
This is what I see regularly when exiting the agent:


Shutting down...
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f47706bca10, pid=20166, tid=139944829835008
#
# JRE version: 6.0_29-b11
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.4-b02 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  0x00007f47706bca10  _fini+0xfcb4b1b8
#
# An error report file with more information is saved as:
# /home/mazz/source/rhq/modules/enterprise/agent/target/rhq-agent/hs_err_pid20166.log
The agent will wait for [0] threads to die
Shutdown complete - agent will now exit.
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
./rhq-agent.sh: line 269: 20166 Aborted                 (core dumped) "/home/software/java/jdk16/bin/java" "-Djava.endorsed
Comment 2 John Mazzitelli 2012-02-02 17:17:33 EST
Created attachment 559149 [details]
hs_err dump file

an example of the hs_err dump.
Comment 3 John Mazzitelli 2013-09-13 16:20:07 EDT

*** This bug has been marked as a duplicate of bug 824850 ***

Note You need to log in before you can comment on or make changes to this bug.