Bug 787020 - Review Request: trafficserver - Apache Traffic Server
Summary: Review Request: trafficserver - Apache Traffic Server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: Package Review
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kalpa Welivitigoda
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: trafficserver (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-02 22:32 UTC by Jan-Frode Myklebust
Modified: 2012-04-18 22:48 UTC (History)
6 users (show)

Fixed In Version: trafficserver-3.0.4-4.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-08 17:04:31 UTC
callkalpa: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jan-Frode Myklebust 2012-02-02 22:32:54 UTC
Re-submitting this since I took over from Zhao Yongming in bz#683463


Description: Apache Traffic Server is fast, scalable and extensible HTTP/1.1
compliant caching proxy server.
Formerly a commercial product, Yahoo! donated it to the Apache Foundation, and
is now an Apache TLP.
site: http://trafficserver.apache.org/


Spec URL: http://blag.tanso.net/code/ats/v3.0.2-0/trafficserver.spec
SRPM URL: http://blag.tanso.net/code/ats/v3.0.2-0/trafficserver-3.0.2-0.el6.src.rpm

$ rpmlint trafficserver-3.0.2-0.el6.src.rpm
trafficserver.src: I: enchant-dictionary-not-found en_US
trafficserver.src:5: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 5)
1 packages and 0 specfiles checked; 0 errors, 1 warnings.

Comment 1 Jan-Frode Myklebust 2012-02-02 22:34:21 UTC
*** Bug 683463 has been marked as a duplicate of this bug. ***

Comment 2 Jan-Frode Myklebust 2012-02-13 10:28:41 UTC
Updated to v3.0.3 (release candidate):


Spec URL: http://blag.tanso.net/code/ats/v3.0.3-0/trafficserver.spec
SRPM URL: http://blag.tanso.net/code/ats/v3.0.2-0/trafficserver-3.0.3-0.el6.src.rpm

Comment 3 Kalpa Welivitigoda 2012-03-08 16:33:36 UTC
Hi Jan,

The link to rpm file is not working. Could you please fix it.

Comment 4 Bill McGonigle 2012-03-08 18:54:51 UTC
Looks like it's just a typo in the URL:

http://blag.tanso.net/code/ats/v3.0.3-0/trafficserver-3.0.3-0.el6.src.rpm

works.

Comment 5 Kalpa Welivitigoda 2012-03-09 14:29:03 UTC
rpmlint trafficserver.spec trafficserver-3.0.3-0.el6.src.rpm 
trafficserver.spec:5: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 5)
trafficserver.src: W: spelling-error Summary(en_US) scalable -> salable, callable, calculable
trafficserver.src: W: spelling-error %description -l en_US scalable -> salable, callable, calculable
trafficserver.src:5: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 5)
1 packages and 1 specfiles checked; 0 errors, 4 warnings.


Please correct the mixed-use-of-spaces-and-tabs

The rest seems ok

Comment 6 Jan-Frode Myklebust 2012-03-10 14:01:51 UTC
Fixed the mixed use of spaces and tabs:

$ rpmlint trafficserver-3.0.3-1.el6.src.rpm 
trafficserver.src: I: enchant-dictionary-not-found en_US
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

http://blag.tanso.net/code/ats/v3.0.3-1/trafficserver.spec
http://blag.tanso.net/code/ats/v3.0.3-1/trafficserver-3.0.3-1.el6.src.rpm

Comment 7 Kalpa Welivitigoda 2012-03-10 14:42:06 UTC
The package is good to go

Comment 8 Jan-Frode Myklebust 2012-03-10 15:22:28 UTC
New Package SCM Request
=======================
Package Name: trafficserver
Short Description: Apache Traffic Server is a fast, scalable and extensible HTTP/1.1 compliant caching proxy server.
Owners: janfrode
Branches: el5 el6
InitialCC:

Comment 9 Zhao Yongming 2012-03-10 17:19:30 UTC
please hold for few days, as we will release 3.0.4 asap, for some important fix.

Comment 10 Jan-Frode Myklebust 2012-03-10 17:44:26 UTC
I'll wait with submitting this package to EPEL until v3.0.4 is done, but this shouldn't hold back getting included in SCM.

BTW Yongming, you should probably look into updating the News and Download sections of http://trafficserver.apache.org/. It's still claiming v3.0.2 is the latest stable release.

Comment 11 Gwyn Ciesla 2012-03-12 12:10:06 UTC
Git done (by process-git-requests).

Kalpa, please take ownership of review BZs.  Thanks!

Comment 12 Kalpa Welivitigoda 2012-03-12 14:59:47 UTC
Jon, I hope I have already done. If not could you please guide me?

Comment 13 Kalpa Welivitigoda 2012-03-12 15:01:33 UTC
sorry. Now only I did it. Thanks

Comment 14 Jan-Frode Myklebust 2012-03-13 07:45:46 UTC


Yongming, the build fails on ppc64 with the message #error "unsupported processor":

    http://koji.fedoraproject.org/koji/getfile?taskID=3884843&name=build.log

is this something that can be fixed ?

Comment 15 Fedora Update System 2012-03-13 08:42:33 UTC
trafficserver-3.0.3-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trafficserver-3.0.3-2.el6

Comment 16 Fedora Update System 2012-03-13 16:23:10 UTC
trafficserver-3.0.3-2.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 17 Fedora Update System 2012-03-18 20:16:16 UTC
trafficserver-3.0.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trafficserver-3.0.3-3.el6

Comment 18 Jan-Frode Myklebust 2012-03-18 20:27:33 UTC
Bill, FYI: I fixed the proxy.config.proxy_name to default to FIXME.example.com (didn't want to mess with post install scripts for this), and pointed default proxy.config.ssl.server.cert.path and proxy.config.ssl.server.private_key.path to your suggested /etc/pki locations. 

Also have gotten upstream to change the initscript to use "traffic_line -x" on reloads, but this isn't included in this package (fixed in v3.1)...

Comment 19 Julian C. Dunn 2012-03-21 04:28:36 UTC
Jan-Frode, I was testing this package on Fedora 16 and the init script seems to hang, although the services are started properly and I can use trafficserver as a forward proxy. I'm not that familiar with this software, so can you give me some information about where I should start looking? This is what happens:


demeter:/etc/trafficserver$ sudo systemctl start trafficserver.service
<hangs until systemctl timeout is reached>
Job failed. See system logs and 'systemctl status' for details.
demeter:/etc/trafficserver$ sudo systemctl status trafficserver.service
[sudo] password for jdunn: 
trafficserver.service - LSB: Startup/shutdown script for the Apache Traffic Server
          Loaded: loaded (/etc/rc.d/init.d/trafficserver)
          Active: failed since Wed, 21 Mar 2012 00:25:44 -0400; 17s ago
         Process: 1663 ExecStart=/etc/rc.d/init.d/trafficserver start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/trafficserver.service
                  ├ 1453 /usr/bin/traffic_cop
                  ├ 1455 /usr/bin/traffic_manager
                  └ 1467 /usr/bin/traffic_server -M -A,9:X

and some relevant log file lines from /var/log/messages:

Mar 21 00:20:44 demeter trafficserver[1663]: Starting Apache Traffic Server: [  OK  ]#015[  OK  ]
Mar 21 00:20:44 demeter systemd[1]: PID file /var/run/trafficserver/cop.pid not readable (yet?) after start.
Mar 21 00:25:44 demeter systemd[1]: trafficserver.service operation timed out. Terminating.
Mar 21 00:25:44 demeter systemd[1]: Unit trafficserver.service entered failed state.

Comment 20 Jan-Frode Myklebust 2012-03-21 07:25:09 UTC
Julian: thanks for testing on F16. Could you please try again with the following trafficserver.service ?

----8<------8<-----8<-------8<------8<-----8<-------8<------8<-----8<---
[Unit]
Description=Apache Traffic Server is a fast, scalable and extensible caching proxy server.
After=syslog.target network.target

[Service]
Type=simple
EnvironmentFile=-/etc/sysconfig/trafficserver
PIDFile=/var/run/trafficserver/cop.pid
ExecStart=/usr/bin/traffic_cop $TC_DAEMON_ARGS
ExecReload=/usr/bin/traffic_line -x

[Install]
WantedBy=multi-user.target
----8<------8<-----8<-------8<------8<-----8<-------8<------8<-----8<------

Comment 21 Julian C. Dunn 2012-03-21 13:33:31 UTC
Thanks, that worked.

I had to delete the SysV init script and drop this into /lib/systemd/system with a systemd --system daemon-reload for good measure. I guess you'll have to do some special handling in the package depending on whether it's running on Fedora or EPEL?

Comment 22 Jan-Frode Myklebust 2012-03-21 14:02:01 UTC
Thanks for verifying that this worked. Much appreciated!

I will fix the package to support fedora soon. Just wanted to get EL6 working first, since that's what I need myself.

Comment 23 Jan-Frode Myklebust 2012-03-21 14:11:08 UTC
Package Change Request
======================
Package Name: trafficserver
New Branches: f15 f16 f17
Owners: janfrode
InitialCC:

Comment 24 Gwyn Ciesla 2012-03-21 14:13:41 UTC
Git done (by process-git-requests).

Comment 25 Jan-Frode Myklebust 2012-03-21 14:44:34 UTC
Julian, I implemented systemd support and launched a build for f16 at:

     http://koji.fedoraproject.org/koji/taskinfo?taskID=3917731

Maybe you could try that (once it's complete), and report if it works ?

Comment 26 Jan-Frode Myklebust 2012-03-21 22:58:15 UTC
This build worked better.. 


   http://koji.fedoraproject.org/koji/taskinfo?taskID=3920721

Comment 27 Julian C. Dunn 2012-03-21 23:54:44 UTC
Thanks, it works great. I do notice though that /var/run/trafficserver/cop.pid never gets created, so systemd complains on reloads:

Mar 21 19:53:14 demeter systemd[1]: PID file /var/run/trafficserver/cop.pid not readable (yet?) after reload.

Not sure if that's a packaging problem or an upstream issue.

Comment 28 Jan-Frode Myklebust 2012-03-22 08:09:00 UTC
Looks like a packaging problem...

For sysv-initscripts the pidfile is created by the initscript, not by the daemon. Not sure how this should work with systemd.

Comment 29 Jan-Frode Myklebust 2012-03-22 08:13:09 UTC
Looks like pidfile isn't needed for type=simple systemd services. I'll just remove it.

Comment 30 Fedora Update System 2012-03-22 08:49:03 UTC
trafficserver-3.0.3-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/trafficserver-3.0.3-6.fc16

Comment 31 Fedora Update System 2012-03-22 09:23:49 UTC
trafficserver-3.0.3-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trafficserver-3.0.3-6.el6

Comment 32 Fedora Update System 2012-03-22 09:23:58 UTC
trafficserver-3.0.3-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/trafficserver-3.0.3-6.fc15

Comment 33 Julian C. Dunn 2012-03-22 16:41:29 UTC
Works great now Jan-Frode. Thanks.

BTW, a small typo in your package "Description" for the next update. It reads "Apache Traffic Server is fast, scalable and extensible HTTP/1.1 compliant caching proxy server." I think you need an "a" before the word "fast"

Comment 34 Fedora Update System 2012-03-22 18:14:57 UTC
trafficserver-3.0.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-1.fc15

Comment 35 Fedora Update System 2012-03-22 18:15:10 UTC
trafficserver-3.0.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-1.el6

Comment 36 Fedora Update System 2012-03-22 18:15:22 UTC
trafficserver-3.0.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-1.fc16

Comment 37 Jan-Frode Myklebust 2012-03-22 18:19:41 UTC
I've been a bit confused about that typo. Have assumes it was some advanced English, since that's the intro line http://trafficserver.apache.org has been using for quite some time.. I see now they've "fixed" it to definitely be wrong.

Comment 38 Leif Hedstrom 2012-03-22 18:49:56 UTC
You can file bugs, or even better, send patches you know ;-). I didn't break it the first time, I broke it good the last time. And now the build system is effed up, but I have corrected it again.

Looking forward to see the packages on EPEL!

Comment 39 Julian C. Dunn 2012-03-23 14:36:46 UTC
I found another problem with this on Fedora 16, which is that after a server is rebooted, /var/run is recreated. Hence, trafficserver refuses to start up because /var/run/trafficserver is missing.

I added this line to trafficserver.service to create the directory with the right permissions, but maybe it's not the most elegant. It works, though:

ExecStartPre=/usr/bin/install -d -o root -g ats -m 775 /var/run/trafficserver

Comment 40 Julian C. Dunn 2012-03-23 14:40:00 UTC
One more thing: I think the EnvironmentFile line has a typo in it. It should be:

EnvironmentFile=/etc/sysconfig/trafficserver

(no leading dash to "/etc")

Comment 41 Jan-Frode Myklebust 2012-03-23 19:54:01 UTC
Julian, according to http://fedoraproject.org/wiki/Packaging:Systemd the leading dash in EnvironmentFile should mean that no error messages are created if the file doesn't exist. So I think this is correct.

Regarding the /var/run/trafficserver, I guess I'll have to create this using tmpfiles.d, ref: http://fedoraproject.org/wiki/Packaging:Tmpfiles.d

Comment 42 Fedora Update System 2012-03-23 20:33:48 UTC
trafficserver-3.0.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-2.fc15

Comment 43 Fedora Update System 2012-03-23 20:34:00 UTC
trafficserver-3.0.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-2.fc16

Comment 44 Fedora Update System 2012-03-23 20:34:10 UTC
trafficserver-3.0.4-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-2.el6

Comment 45 Jan-Frode Myklebust 2012-03-23 20:40:18 UTC
This trafficserver-3.0.4-2 release should fix the /var/run/trafficserver-creation on boot.

Comment 46 Fedora Update System 2012-04-08 17:04:31 UTC
trafficserver-3.0.4-2.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 47 Fedora Update System 2012-04-09 01:57:09 UTC
trafficserver-3.0.4-2.fc15 has been pushed to the Fedora 15 stable repository.

Comment 48 Fedora Update System 2012-04-09 01:57:29 UTC
trafficserver-3.0.4-2.fc16 has been pushed to the Fedora 16 stable repository.

Comment 49 Fedora Update System 2012-04-11 10:25:10 UTC
trafficserver-3.0.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/trafficserver-3.0.4-4.fc17

Comment 50 Fedora Update System 2012-04-18 22:48:54 UTC
trafficserver-3.0.4-4.fc17 has been pushed to the Fedora 17 stable repository.


Note You need to log in before you can comment on or make changes to this bug.