This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 787044 - [abrt] kernel: [141287.119475] WARNING: at lib/list_debug.c:47 __list_del_entry+0x63/0xd0()
[abrt] kernel: [141287.119475] WARNING: at lib/list_debug.c:47 __list_del_ent...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
abrt_hash:23259ad91d4870a8407a2116fa7...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-02-02 20:42 EST by Joshua
Modified: 2012-05-14 13:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua 2012-02-02 20:42:11 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.8-2.fc16.x86_64 root=/dev/mapper/vg_belldandy-lv_root ro rd.lvm.lv=vg_belldandy/lv_root rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_belldandy/lv_swap LANG=en_US.UTF-8
kernel:         3.1.8-2.fc16.x86_64
reason:         [141287.119475] WARNING: at lib/list_debug.c:47 __list_del_entry+0x63/0xd0()
time:           Thu 19 Jan 2012 03:20:57 PM CST

backtrace:
:[141287.119475] WARNING: at lib/list_debug.c:47 __list_del_entry+0x63/0xd0()
:[141287.119477] Hardware name: 1068A8U
:[141287.119479] list_del corruption, ffff88013008e520->next is LIST_POISON1 (dead000000100100)
:[141287.119481] Modules linked in: snd_usb_audio snd_usbmidi_lib snd_rawmidi nls_utf8 udf crc_itu_t usblp vfat fat usb_storage tcp_lp ppdev parport_pc lp parport fuse lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack uvcvideo videodev media v4l2_compat_ioctl32 snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore uinput iTCO_wdt iTCO_vendor_support sunrpc arc4 brcmsmac mac80211 brcmutil cfg80211 ideapad_laptop sparse_keymap rfkill crc8 r8169 mii snd_page_alloc joydev cordic microcode i2c_i801 wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[141287.119531] Pid: 1853, comm: pm-hibernate Not tainted 3.1.8-2.fc16.x86_64 #1
:[141287.119532] Call Trace:
:[141287.119539]  [<ffffffff8106b7ef>] warn_slowpath_common+0x7f/0xc0
:[141287.119543]  [<ffffffff8106b8e6>] warn_slowpath_fmt+0x46/0x50
:[141287.119546]  [<ffffffff812bcca3>] __list_del_entry+0x63/0xd0
:[141287.119549]  [<ffffffff812bcd21>] list_del+0x11/0x40
:[141287.119554]  [<ffffffff8122f8eb>] jbd2_journal_release_jbd_inode+0xeb/0x110
:[141287.119559]  [<ffffffff8120bdb1>] ext4_clear_inode+0x51/0x80
:[141287.119563]  [<ffffffff811f4b05>] ext4_evict_inode+0x75/0x430
:[141287.119566]  [<ffffffff8118bcda>] evict+0x9a/0x1a0
:[141287.119568]  [<ffffffff8118c32e>] dispose_list+0x3e/0x60
:[141287.119571]  [<ffffffff8118cce2>] prune_icache_sb+0x142/0x2d0
:[141287.119575]  [<ffffffff81175bdb>] prune_super+0x13b/0x1a0
:[141287.119580]  [<ffffffff81125ff1>] shrink_slab+0x141/0x2f0
:[141287.119584]  [<ffffffff81128e60>] do_try_to_free_pages+0x3e0/0x4c0
:[141287.119588]  [<ffffffff81128fe7>] shrink_all_memory+0xa7/0xc0
:[141287.119592]  [<ffffffff810af431>] hibernate_preallocate_memory+0x1e1/0x390
:[141287.119598]  [<ffffffff81393c6f>] ? dpm_prepare+0x23f/0x2a0
:[141287.119601]  [<ffffffff810ad895>] hibernation_snapshot+0x95/0x320
:[141287.119604]  [<ffffffff810ae11e>] hibernate+0xee/0x200
:[141287.119606]  [<ffffffff810ac6cc>] state_store+0xdc/0xf0
:[141287.119610]  [<ffffffff81152c13>] ? alloc_pages_current+0xa3/0x110
:[141287.119615]  [<ffffffff812a9c8f>] kobj_attr_store+0xf/0x30
:[141287.119619]  [<ffffffff811e10bf>] sysfs_write_file+0xef/0x170
:[141287.119622]  [<ffffffff81172ad3>] vfs_write+0xb3/0x180
:[141287.119625]  [<ffffffff81172dfa>] sys_write+0x4a/0x90
:[141287.119629]  [<ffffffff815dd142>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: f42627c8-7713-456c-b893-acfd3fa3297f
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3991.23
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Pentium(R) CPU B940 @ 2.00GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 2
:CPU Speed: 2000
:System Memory: 3869
:System Swap: 4095
:Vendor: LENOVO
:System: 1068A8U Lenovo B570
:Form factor: Notebook
:Kernel: 3.1.9-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:6058:14709) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:262:6058:14709) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:14709) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:14709) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:14709) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:6058:14709) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:6058:14709) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33128:6058:14709) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(5348:18215:5348:1307) pci, brcmsmac, NETWORK, BCM4313 802.11b/g/n Wireless LAN Controller
:(32902:7171:6058:14709) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:14709) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:14709) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:14709) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:14709) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_belldandy-lv_root / ext4 4096 4096 119016720 96128344 90082648 30228480 29978810 29978810
:/dev/sda1 /boot ext4 1024 1024 495844 410317 384717 128016 127788 127788
:/dev/sr0 WITHHELD udf 2048 2048 2038006 0 0 80 0 0
:
Comment 1 Josh Boyer 2012-02-03 09:33:41 EST
Eric, looks like another issue coming out of hibernate
Comment 2 Dave Jones 2012-03-09 13:04:46 EST
if you could run the kernel-debug build at
http://koji.fedoraproject.org/koji/buildinfo?buildID=304798 that might turn up
a different trace that might be helpful to us to track this down.

(it's going to be considerably slower than the regular build, due to the extra
checking).
Comment 3 Dave Jones 2012-03-22 12:53:29 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 12:57:13 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 13:08:21 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Josh Boyer 2012-03-28 14:00:45 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.