Bug 787117 - glusterfs core dumps upon rebalance operation
glusterfs core dumps upon rebalance operation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Amar Tumballi
:
: 787182 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-03 03:21 EST by shylesh
Modified: 2013-12-18 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:40:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: master
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-02-03 03:21:08 EST
Description of problem:

glusterfs core dumps upon rebalance operation
Version-Release number of selected component (if applicable):
Mainline

How reproducible:
often

Steps to Reproduce:
1. create a distribute volume 
2. fill up with some files
3. add another brick and initiate rebalance
  
Actual results:
rebalance fails dumping the core

Expected results:


Additional info:


#0  __pthread_mutex_lock (mutex=0x38) at pthread_mutex_lock.c:50
#1  0x00007f24e04a24b1 in client3_1_fremovexattr (frame=0x7f24e3f65b0c, this=0x12ba660, data=0x7f24d70c5970)
    at client3_1-fops.c:4642
#2  0x00007f24e0488208 in client_fremovexattr (frame=0x7f24e3f65b0c, this=0x12ba660, fd=0x7f24d8b86088, 
    name=0x7f24e026f15a "trusted.glusterfs.dht.linkto") at client.c:1448
#3  0x00007f24e59bf5fd in syncop_fremovexattr (subvol=0x12ba660, fd=0x7f24d8b86088, 
    name=0x7f24e026f15a "trusted.glusterfs.dht.linkto") at syncop.c:498
#4  0x00007f24e02319c9 in dht_migrate_file (this=0x12bbea0, loc=0x12c96b8, from=0x12b9380, to=0x12ba660, flag=1)
    at dht-rebalance.c:692
#5  0x00007f24e0231cb7 in rebalance_task (data=0x7f24e3f64aec) at dht-rebalance.c:739
#6  0x00007f24e59bd11e in synctask_wrap (old_task=0x12c9d40) at syncop.c:109
#7  0x00007f24e4dbb1a0 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#8  0x0000000000000000 in ?? ()
============================================================================

[2012-02-03 13:29:52.785134] E [stat-prefetch.c:691:sp_remove_caches_from_all_fds_opened] (-->/usr/local/lib/glusterfs/3git/xlator/mount/fuse.so(fuse_setxattr_resume+0x892) [0x7f24e2bd7aa3] (-->/usr/local/lib/glusterfs/3git/xlator/debug/io-stats.so(io_stats_setxattr+0x2cf) [0x7f24db593526] (-->/usr/local/lib/glusterfs/3git/xlator/performance/stat-prefetch.so(sp_setxattr+0x138) [0x7f24db7b4d17]))) 0-test-stat-prefetch: invalid argument: inode
> [2012-02-03 13:29:52.785202] I [dht-common.c:2237:dht_setxattr] 0-test-dht: fixing the layout of /
> [2012-02-03 13:29:52.802398] I [dht-rebalance.c:510:dht_migrate_file] 0-test-dht: /here: attempting to move from test-client-0 to test-client-1
> pending frames:
>
> frame : type(1) op(SETXATTR)
> frame : type(1) op(SETXATTR)
>
> patchset: git://git.gluster.com/glusterfs.git
> signal received: 11
> time of crash: 2012-02-03 13:29:53
> configuration details:
> argp 1
> backtrace 1
> dlfcn 1
> fdatasync 1
> libpthread 1
> llistxattr 1
> setfsid 1
> spinlock 1
> epoll.h 1
> xattr.h 1
Comment 1 shylesh 2012-02-03 03:54:03 EST
gdb) f 1
#1  0x00007f24e04a24b1 in client3_1_fremovexattr (frame=0x7f24e3f65b0c, this=0x12ba660, data=0x7f24d70c5970)
    at client3_1-fops.c:4644
4644            CLIENT_GET_REMOTE_FD(conf, args->fd, remote_fd, op_errno, unwind);

(gdb) p conf
$1 = (clnt_conf_t *) 0x0

conf is NULL
Comment 2 Amar Tumballi 2012-02-05 01:12:20 EST
*** Bug 787182 has been marked as a duplicate of this bug. ***
Comment 3 Anand Avati 2012-02-07 07:21:50 EST
CHANGE: http://review.gluster.com/2712 (protocol/client: assign the right value to 'conf' before de-refing it) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 4 shylesh 2012-03-29 09:14:14 EDT
works fine

Note You need to log in before you can comment on or make changes to this bug.