Bug 787237 - [ia64-pv] swap does't take all remaining space if told to
[ia64-pv] swap does't take all remaining space if told to
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: rhel59rtt
  Show dependency treegraph
 
Reported: 2012-02-03 11:16 EST by Alexander Todorov
Modified: 2012-02-07 10:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 10:32:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2012-02-03 11:16:21 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create Xen PV guest on ia64.
2. Delete all previous partitions
3. Create /boot/efi - 100 MB
4. Create swap partition and make it use all remaining free space
  
Actual results:
swap is 2047MB and I have 17 GB of free space left on the disk. 

Expected results:
Swap will take all the rest free space. NB: I was planning for / to be on separate iscsi disk. 

Additional info:
Comment 1 Chris Lumens 2012-02-07 10:32:26 EST
This is on purpose - we clamp the swap space to the maximum given by the swap suggestion to prevent swap from growing to consume all space.  This has been the behavior since early 2003, so it's really too late to chance it now.

Note You need to log in before you can comment on or make changes to this bug.