Bug 78745 - Add option to skip lvm scan
Add option to skip lvm scan
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-28 10:24 EST by Robert Armstrong
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Armstrong 2002-11-28 10:24:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
While installing Redhat 8.0 from hard drive, I get messages saying the partition
table is "inconsistent."  If I ignore the messages and continue, the installer
crashes and tells me "vgscan failed."  I partitioned my harddrive using FIPS.  I
am booting from a floppy drive, using the boot.img file I obtained from a Redhat
7.3 distribution I purchased in China.  I cannot boot directly from the CDs that
came with that distribution, and when I try to boot from a floppy and then
install from the CD, the installer tells me it cannot find the images.  So I
downloaded the 8.0 iso images from the website. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to install Redhat Linux booting from floppy.
2.
3.
	

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/text.py", line 446,
in run
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
150, in gotoNext
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/dispatch.py", line
215, in moveStep
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/partitioning.py",
line 57, in partitionObjectsInitialize
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/partitions.py",
line 184, in setFromDisk
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/lvm.py", line 38,
in vgscan
SystemError: vgscan failed

Local variables in innermost frame:
rc: 24320


Dispatcher instance, containing members:
method: HardDriveInstallMethod instance, containing members:
  messageWindow: <bound method InstallInterface.messageWindow of
<text.InstallInterface instance at 0x85240f4>>
  discImages: {1: psyche-i386-disc1.iso}
  fnames: {}
  isoDir: /tmp/isodir/
  tree: None
  rootPath: /mnt/sysimage
  fstype: vfat
  device: hda5
  path: 
  mediaIsMounted: 0
  isoDirIsMounted: 0
Comment 1 Michael Fulbright 2002-12-02 11:04:35 EST
Have you ever used LVM on these drives?
Comment 2 Robert Armstrong 2002-12-02 18:28:25 EST
I don't think so.  What is "LVM?"
Comment 3 Michael Fulbright 2003-01-02 21:42:38 EST
LVM stands for 'Logical Volume Manager'.

The vgscan command looks for existing LVM installations.  Apparently the command
is failing on your system because it is confused by your current partitioning.

Comment 4 Michael Fulbright 2003-01-02 21:43:13 EST
Noting we should add a option to skip this scan since it seems unrealiable on
certain systems.
Comment 5 Jeremy Katz 2003-01-10 01:56:03 EST
Instead added code so that if vgscan fails, we just disable lvm.
Comment 6 Brent Fox 2003-05-25 10:54:35 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.