Bug 78747 - redhat-config-xfree produces dangerous modes
redhat-config-xfree produces dangerous modes
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-28 14:10 EST by Alan Cox
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 17:04:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-11-28 14:10:58 EST
Description of Problem:

Run redhat-config-xfree86 because the wrong video was detected. It starts X11,
then fails. It switches to a new config, and then tries to blow up the monitor

The new configuration it uses should honour the monitor settings in the existing
configuration (and maybe if it still fails then the generic vga 'safe' values).
Certainly if it cannot get a DDC probe of the monitor clocks.

Alan
Comment 1 Alexander Larsson 2002-11-29 03:02:38 EST
It should maybe keep the old monitor info, although those could be bogus too.

At the moment if falls back to:
Generic Extended Super VGA, 800x600 @ 60 Hz, 640x480 @ 72 Hz; 0; 31.5-37.9; 50-70

I thought that was pretty safe these days?
Comment 2 Brent Fox 2003-01-06 01:49:06 EST
alan: can you try with redhat-config-xfree86-0.7.1-2 out of Rawhide and see if
that's any better?  Also, what happens if you move the XF86Config file out of
the way entirely and try to let redhat-config-xfree86 generate a file from scratch?
Comment 3 Brent Fox 2003-02-18 17:31:22 EST
ping?
Comment 4 Alan Cox 2003-02-18 19:10:46 EST
Pong. will look at this

I saw the 800x600 fallback in the beta work for other reasons.
Comment 5 Brent Fox 2003-09-04 17:04:08 EDT
Ok, well, please reopen this bug if the problem still occurs in the Severn betas.

Note You need to log in before you can comment on or make changes to this bug.