Bug 787706 - fence_ipmilan doesn't respect power_wait option for power off
Summary: fence_ipmilan doesn't respect power_wait option for power off
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-06 15:14 UTC by Vlastimil Holer
Modified: 2018-11-28 20:51 UTC (History)
3 users (show)

Fixed In Version: fence-agents-3.1.5-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 14:40:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
apply power_wait timeout for "power off" operation (386 bytes, patch)
2012-02-06 15:15 UTC, Vlastimil Holer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0943 normal SHIPPED_LIVE fence-agents bug fix and enhancement update 2012-06-19 21:00:16 UTC

Description Vlastimil Holer 2012-02-06 15:14:06 UTC
Description of problem:
I have a machine where "power off" operation over IPMI takes longer time. The manual page for fence_ipmilan agent descripts this option:

<cite>
  power_wait
    Wait X seconds after on/off operation (Default Value: 2)
</cite>

After reading this I believed this sleep should happen after each power change. In the fact it doesn't, it's effective only for "power on" operation. For "power off" there is just a sleep with default length (2 seconds).

Attached simple patch applies "power_wait" sleep after "power off" as well. I have tested this patch on my machine and got expected behaviour.

Version-Release number of selected component (if applicable):
fence-agents-3.1.5-10.el6

Actual results:
Default "power off" timeouts

Expected results:
Configurable "power off" timeouts

Comment 1 Vlastimil Holer 2012-02-06 15:15:15 UTC
Created attachment 559656 [details]
apply power_wait timeout for "power off" operation

Comment 3 Marek Grac 2012-02-08 16:42:04 UTC
Thanks for reporting,

patch is now part of upstream:

http://git.fedorahosted.org/git/?p=fence-agents.git;a=commit;h=9fb1a85034eb8f94a766ba9766a75924947f5e77


Unit test:

fence_ipmilan ... -o on
time fence_ipmilan ... -T 10 -o off

time needed after aplying patch should be higher by 8 seconds (2 seconds before changed to -T 10 seconds)

Comment 6 Marek Grac 2012-02-20 16:03:11 UTC
Results of test unit:

fence_ipmilan -o on -a IPMILAN_IP -l USERID -p PASSWORD
Powering on machine @ IPMI:IPMILAN_IP...Done
[marx@nox ipmilan]$ time fence_ipmilan -o off -a IPMILAN_IP -l LOGIN -p PASSWORD
Powering off machine @ IPMI:IPMILAN_IP...Done

real	0m12.991s
user	0m0.001s
sys	0m0.010s

fence_ipmilan -o on -a IPMILAN_IP -l USERID -p PASSWORD
Powering on machine @ IPMI:IPMILAN_IP...Done
[marx@nox ipmilan]$ time fence_ipmilan -o off -a IPMILAN_IP -l LOGIN -p PASSWORD -T 30
Powering off machine @ IPMI:IPMILAN_IP...Done

real	0m33.041s
user	0m0.003s
sys	0m0.008s

==

without applying patch there was no difference due to -T option (time varies due to ipmi itself; 30 seconds timeout is better for testing than originally porposed 10 seconds.

Comment 9 errata-xmlrpc 2012-06-20 14:40:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0943.html


Note You need to log in before you can comment on or make changes to this bug.