Bug 78772 - rpc.rstatd can not handle /proc/stat output
Summary: rpc.rstatd can not handle /proc/stat output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rusers
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 15:25 UTC by Michael Plagge
Modified: 2015-03-05 01:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 21:05:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
diff against rstat_proc.c from rusers-0.0.17 (2.41 KB, patch)
2002-11-29 15:41 UTC, Michael Plagge
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:278 high SHIPPED_LIVE Updated rusers package available 2003-02-07 15:19:58 UTC

Description Michael Plagge 2002-11-29 15:25:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Linux 2.4.7-10 i686; U) Opera 6.1  [en]

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
starting rpc.rstatd
using rup on a remote host
rstatd daemon crahses with segfault


	

Actual Results:  core dump

Expected Results:  returning data to rup

Additional info:

diff to follow

Comment 1 Michael Plagge 2002-11-29 15:41:47 UTC
Created attachment 86885 [details]
diff against rstat_proc.c from rusers-0.0.17

Comment 2 Michael Plagge 2002-11-29 16:00:22 UTC
Output from /proc/stat normal Red Hat 7.3:  
.  
intr 3030199 2250856 18029 ... 
. 
 
Output from /proc/stat Red Hat Linux Advanced Server release 2.1AS: 
. 
intr 10974542 1009005264 1000000060... 
. 
 
rstatd compares if first number of intr-line is bigger than second 
number. If this is not the case assert() is called. 
 
Second problem seems to be, that sscanf() can not handle NULL pointer 
as first argument, therefore i added tests for NULL pointer in front 
of each sscanf line 
.

Comment 3 Phil Knirsch 2002-12-05 10:52:02 UTC
OK, verified that the patch for rstatd.c for later kernels fixes the problem.

Will open a new AS errata today and build updated packages.

Read ya, Phil

Comment 4 John Flanagan 2003-02-14 21:05:08 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-278.html



Note You need to log in before you can comment on or make changes to this bug.