Bug 78773 - up2date not executing..file format not recognized
Summary: up2date not executing..file format not recognized
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 16:00 UTC by Kyle
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-08 18:44:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date stderr (163.59 KB, text/plain)
2003-02-08 17:23 UTC, Kyle
no flags Details

Description Kyle 2002-11-29 16:00:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
When i click on the up2date icon it does not execute or if i type in the cmd it
does not work...when i do a backtrace gdb up2date i get this message:

[root@localhost root]# gdb up2date
GNU gdb Red Hat Linux (5.2.1-4)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"..."/usr/sbin/up2date": not in
executable format: File format not recognized



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.click up2date icon/or type cmd up2date
2.
3.
	

Additional info:

this is the second time this has happened. i would have to reinstall up2date.

Comment 1 Michael Lee Yohe 2002-12-01 19:25:31 UTC
The error you are receiving is because gdb attempts to grab information from the
object code of a binary file.  "up2date" is not a binary application - it is
actually a Python script:

$ file /usr/sbin/up2date
/usr/sbin/up2date: a /usr/bin/python -u script text executable

Instead you could provide the strace output of the execution:

# strace /usr/sbin/up2date 2> output_up2date.stderr

Attach output_up2date.stderr to this bug.


Comment 2 Adrian Likins 2002-12-13 22:21:03 UTC
How does up2date fail if ran from the command line?

Do you get error messages? if so, what are they?

Comment 3 Kyle 2003-02-08 17:23:12 UTC
Created attachment 89945 [details]
up2date stderr

Comment 4 Kyle 2003-02-08 18:44:59 UTC
apparently all you need to do is rm -f /var/lib/rpm__db*...conflict w/ the rpm 
bug...closed 

Comment 5 Kyle 2003-02-08 19:11:35 UTC
check that....its rm -f /var/lib/rpm/__db*


Note You need to log in before you can comment on or make changes to this bug.