Bug 78775 - installer fails when trying to do install from hardrive iso image
installer fails when trying to do install from hardrive iso image
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-11-29 11:46 EST by Kie
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-24 12:03:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kie 2002-11-29 11:46:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Trying to install Redhat Linux 8.0 on my Sharp PC-UM10 laptop
the cdrom drive has a usb connection and booting from cdrom only
gives option to install from hard-drive
so i copied iso images to hard-drive and then tried to install.
the install fails.

this worked for redhat 7.3 when i did it a long time ago,
and i then upgrading to 8.0 from 7.3 quite a long time ago as well
i recently had to return laptop to sharp due to hardware failure
so had to wipe linux before returning to them as they told me that they would
not look at it if it had linux on it.

alternatively if i could do a network install this would be even better
however i do not have a floppy drive so i have no way to run netboot.img

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. copy iso images to hard-drive
2. put redhat installation cd1 in cdrom drive
3. set machine to boot from cdrom
4. reboot machine

Actual Results:  install gets up to choose method,
offers only one choice hard-drive,
give location of iso-images, proceed 

Expected Results:  redhat linux should be installed

Additional info:

when trying to do install from hard-drive 
can't see all of the errors as scrolls off screen
and does not allow me to scroll back up
but here are the lines that i could see

Files "/usr/src/build/148651-i386/install//usr/lib/anaconda/image.py"
line 342 in findIsoImages,
text.py line 275 in messageWindow,
text.py line 115 in __init__
file "/usr/lib/python2.2/site-packages/snack.py" line 547
in ButtonChoiceWindow
AttributeError: 'NoneType' object has no attribute 'height'
install exited abnormally
it then sends termination signals and unmounts filesystems
Comment 1 Michael Fulbright 2002-12-06 12:34:52 EST
You can do a network install booting from CD.  Type 'linux askmethod' at the
boot prompt.
Comment 2 Kie 2002-12-06 13:44:56 EST
i did type askmethod from the cd but was only presented with the option to
install from the hard-drive (ethernet is realtek 8139c)
btw i eventually did manage to install by borrowing a usb floppy drive and then
doing an install over ftp (using bootnet.img and drvnet.img)
btw trying to use the iso images on the hard-drive from the floppy also gave me
the same problem as trying from the cd.
Comment 3 Michael Fulbright 2003-01-02 21:48:51 EST
Jeremy shouldnt the realtek driver be available on the CD image as well?
Comment 4 Jeremy Katz 2003-01-02 23:03:26 EST
The error you're getting from the ISO images looks to be due to a corrupt iso. 
You should boot with 'linux mediacheck' to verify the images.  Also, what driver
does the 8139 card you have use?
Comment 5 Kie 2003-01-06 02:31:03 EST
I think I did linuxmediacheck  on the CDs and there wasn't any problem,
and I know for certain that I used the iso's on my one machine to burn the CDs
that I used for the install, and I copied over these iso's to the laptop when i
tried to do the install from hard drive.

as to the driver for the Realtek 8139c
kie@sharp:~ $ /sbin/lsmod | grep 8139
8139too                17704   1
mii                     2156   0 [8139too]
Comment 6 Jeremy Katz 2003-03-24 12:03:32 EST
This works for me here on the rtl8139 card I have.  Unfortunately, without exact
hardware there's not a lot more I can say about this.

Note You need to log in before you can comment on or make changes to this bug.