Bug 78784 - bad post-install/pre-remove config for saving mixer settings
bad post-install/pre-remove config for saving mixer settings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-29 16:42 EST by Need Real Name
Modified: 2014-03-16 22:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-29 16:42:29 EST
In what looks like an attempt to save mixer levels for the user, Red Hat puts
this in modules.conf:

alias sound-slot-0 sb
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

While a valiant attempt, it should be apparent why it never works. The drivers
aren't ever removed, so pre-remove never executes. The mixer level saving should
either be added to initscripts to occur at boot, or this pre-remove line should
be removed entirely. As is, it causes unpredictable behavior. (Modified mixer
levels are never saved unless a user for some reason manually removes the
driver. As they never saw this behavior before, it would be unexpected, and,
maybe there wanted to RESTORE default mixer levels (and are going about it
wrong), this would cause DATALOSS and permanently lose them sensible mixer
levels that are loaded with the drivers)
Comment 1 Bill Nottingham 2005-09-29 17:22:34 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

This should be solved with the saving in /etc/init.d/halt, and loading on module
load, in current releases.

Note You need to log in before you can comment on or make changes to this bug.