Bug 78786 - redhat-config-date fails to launch under X or in shell
Summary: redhat-config-date fails to launch under X or in shell
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dateconfig
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 23:03 UTC by Ronald D. Edge
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-30 11:06:32 UTC


Attachments (Terms of Use)

Description Ronald D. Edge 2002-11-29 23:03:47 UTC
Description of Problem:

New install of RedHat 8.0 Professional. Using KDE desktop. Try to launch Date &
Time configuration tool from 'K' System Settings menu. App does not appear. No
errors. Nada. In command shell window, try to launch and get the following:

[root@valhalla root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'

Version-Release number of selected component (if applicable):


How Reproducible:

As above, every time. I finally had to figure out the command line date command
to set the system clock. Boy, was that ever intuitive. The man page is useless.
Found a page on web with examples.

Steps to Reproduce:
1. select from K Panel menu option. Nothing happens.
2. enter command shell redhat-config-date, get errors above. every time.
3. 

Actual Results:


Expected Results:


Additional Information:
	
I pretty much installed most of available options, since this is a workstation
behind my firewall/router, as a learning machine. I am assuming the date time
config app is supposed to be installed, since it appeared on the menu.

Comment 1 Ronald D. Edge 2002-11-30 11:06:25 UTC
Also get error this way:
open Konquerer KDE file manager
nav to /usr/bin/redhat-config-date  executable 
click to launch
get error pop message "unknown error"

Oh, and then I opened a text file 
  etc/pam.d/redhat-config-date
and when hit 'back' in the file manager, it crashed. Doh.
And amazingly enough, that reproduces:
1. open KDE file manager
2. do a search on 'redhat-config-date'
3. click the text file above to open and view it
4. then click the back arrow (not the up arrow) in toolbar of file manager

Thud. Crashed file manager everytime.



Comment 2 Brent Fox 2002-12-11 16:52:15 UTC

*** This bug has been marked as a duplicate of 76313 ***


Note You need to log in before you can comment on or make changes to this bug.