Bug 7879 - Installation Exception Error - Traceback occured
Installation Exception Error - Traceback occured
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-18 15:10 EST by pstrang
Modified: 2015-01-07 18:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 13:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pstrang 1999-12-18 15:10:36 EST
A problem that many people have had, but no one seems to know how to fix or
get around this problem.  Nothing to help in the FAQs, Errata, RedHat 6.1
Gotchas, newsgroups, etc.  Not even in the updated installation images.
I've tried all methods, boot, updates, bootnet.  Same errors.

This problem occurs while initializing package installation (boot cdrom,
hard drive install, and net install); even with updated boot images.

RedHat 6.1 Gotchas reports faulty RPM package in pythlon and to try another
mirror.  I've tried RedHat 6.1 Official CD x86, ftp.redhat.com and
ftp.cdrom.com, all have the same installation exception/crash.

Reported details are below.  My guess is that install images for 6.1
incorrectly identify a Diamond Viper 550 (Nvidia Riva TNT based chipset) as
a Nvidia Riva 128 chipset.  While setting up....a traceback error occurs.
The user/installer cannot change the probed chipset (not even in expert
mode); like it was possible with 6.0.

> Hi !    and thanks for any help !
>
> I'm trying to install RedHat Linux 6.1.
> I download the directory  i386 and all its sub's, and I
> use loadlin to start the process.
> It all worked fine .... disk druild, ...... ,add user, but then
> I get a message looks like:
>
> Traceback (innermost last):
>     file "/usr/bin/anaconda.real",
> line 225, in ?
>     intfr.run(todo, test=test)
> file "/tmp/lib/python1.5/site-packages/text.py",
>     line 1000, in run
>     rc=apply (step[1](),step[2])
> .
> .
> .
> .and more....
>
> at the end of the message I can choose : debug or exit.

I have the same problem on an Abit BH6 mobo with IDE hard drive and CDROM.
I also have a TNT video card.

I cannot find anything to help me with this problem.

RedHat 6.1 installed flawlessly (except for known install bugs) on my ASUS
P2B-S with SCSI hard drive and CDROM.  With a Voodoo3 3000 video card.
Comment 1 Tristan Juricek 2000-02-14 00:55:59 EST
I've experienced what I think is a similar error in installing 6.1.  The rest
of the traceback loop from what was written above for me is:

...
    File "/tmp/lib/python1.5/site-packages/text.py", line 468, in __call__
        todo.getCompsList()
    File "/tmp/lib/python1.5/site-packages/todo.py", line 942, in getCompsList
        self.getHeaderList()
    File "/tmp/lib/python1.5/site-packages/todo.py", line 930, in getHeaderList
        self.hdList = self.method.readHeaders()
    File "/tmp/lib/python1.5/site-packages/harddrive.py", line 46, in
readHeaders
        return Headerlist(h1)
    File "/tmp/lib/python1.5/site-packages/comps.py", line 50, in __init__
        name = h[rpm.RPMTAG_NAME]
TypeError : unscriptable object

Hopefully this provides solvable information.  If anything else is needed, let
me know.  I'll try downloading from a different mirror from what I did before,
if it happens that this is just a bad download.
Comment 2 Tristan Juricek 2000-02-16 00:03:59 EST
Whoops, I just found a message (8683) that had my error.  I had to delete "ls-
lr" from my RPMS directory.
Comment 3 Jay Turner 2000-02-16 08:09:59 EST
I would actually need you to post the reminder of that traceback that you are
getting.  The traceback shows the stuff on the stack when the error occurred, so
the end of the traceback actually shows what went wrong.  Without it, I cannot
even hesitate to guess what your problem is.
Comment 4 Jay Turner 2000-04-17 13:12:59 EDT
Closing due to lack of activity.

Note You need to log in before you can comment on or make changes to this bug.