Bug 788042 - LibreOffice wouldn't start with --quickstart
Summary: LibreOffice wouldn't start with --quickstart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-07 10:31 UTC by Tomas Pelka
Modified: 2012-06-20 12:53 UTC (History)
0 users

Fixed In Version: libreoffice-3.4.5.2-4.el6
Doc Type: Bug Fix
Doc Text:
Cause: new faster startup helper not aware of the systray feature Consequence: activating the systray feature from the command line caused the splashscreen to not be closed Fix: extend the startup helper to be systray feature aware Result: activating the systray feature from the command line now results in the splashscreen closing when the application has completed startup
Clone Of:
Environment:
Last Closed: 2012-06-20 12:53:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
lo strace (71.92 KB, text/plain)
2012-02-07 10:34 UTC, Tomas Pelka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0798 normal SHIPPED_LIVE new packages: libreoffice 2012-06-19 21:00:52 UTC

Description Tomas Pelka 2012-02-07 10:31:05 UTC
Description of problem:
LibreOffice wouldn't start with --quickstart. Just the splash screen appears, no progress indicated.  

Version-Release number of selected component (if applicable):
libreoffice-*-3.4.5.2-1.el6

How reproducible:
100%

Steps to Reproduce:
1. run soffice --quickstart
2.
3.
  
Actual results:
lo wouldn't start

Expected results:
lo should start together with quickstarter

Additional info:
There is no LibreOffice component for Rhel6, so I'm filing this issue again OOO.org.

Comment 1 Tomas Pelka 2012-02-07 10:34:02 UTC
Created attachment 559906 [details]
lo strace

strace -o lo.strace soffice --quickstart

lo hung up

Comment 2 Caolan McNamara 2012-02-07 12:01:54 UTC
looks like it does start, except the splash screen doesn't go away.

Comment 8 Caolan McNamara 2012-05-01 09:57:27 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: new faster startup helper not aware of the systray feature

Consequence: activating the systray feature from the command line caused the splashscreen to not be closed

Fix: extend the startup helper to be systray feature aware

Result: activating the systray feature from the command line now results in the splashscreen closing when the application has completed startup

Comment 10 errata-xmlrpc 2012-06-20 12:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html


Note You need to log in before you can comment on or make changes to this bug.