This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 788118 - libvir: operation virDomainSetVcpus/virDomainSetMemory forbidden for read only access
libvir: operation virDomainSetVcpus/virDomainSetMemory forbidden for read onl...
Status: CLOSED DUPLICATE of bug 796658
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: sat541-triage space18
  Show dependency treegraph
 
Reported: 2012-02-07 09:38 EST by Pavel Studeník
Modified: 2012-11-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 04:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2012-02-07 09:38:47 EST
Description of problem:
I can't change allocation of CPU and RAM of the guest on RHN/Virtualization (webui tab "virtualization"). I used KVM virtualization. Application rhn_check failed with error (6), 'Fatal error in Python code occured, that is VIR_FROM_DOM (Error when operating on a domain) from virErrorDomain. 

* libvir: Domain error : operation virDomainSetVcpus forbidden for read only access
* libvir: Domain error : operation virDomainSetMemory forbidden for read only access

Version-Release number of selected component (if applicable):
rhn-virtualization-host-5.4.32-1.el5

How reproducible:
Always

Steps to Reproduce:
1. Install kvm guest with RHEL5/RHEL6
2. Try to change size of memory or number of CPU. WebUI-> choose host -> tab "virtualization" -> choose guest -> 
  "Set virtual CPU/Memory allocation to equal.."
3. rhn_check -vv

Actual results:
When I tried change number of cpu:
>> rhn_check -vv 
...
libvir: Domain error : operation virDomainSetVcpus forbidden for read only access
D: Sending back response((6,), 'Fatal error in Python code occured', {})

When I tried change size of memory:
>> rhn_check -vv 
...
libvir: Domain error : operation virDomainSetMemory forbidden for read only access
D: Sending back response((6,), 'Fatal error in Python code occured', {})
Comment 1 Milan Zazrivec 2012-04-02 04:16:07 EDT
This problem has been resolved in bug #796658

rhn-virtualization-host-5.4.32-1.el5 comes from Spacewalk, so I'm changing
the bug product/component to Spacewalk/Client.

*** This bug has been marked as a duplicate of bug 796658 ***

Note You need to log in before you can comment on or make changes to this bug.