Bug 78818 - usb keyboard, does not work with usb modules loaded
usb keyboard, does not work with usb modules loaded
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-01 08:09 EST by rj_iyer
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel Log (14.58 KB, text/plain)
2003-04-09 12:46 EDT, rj_iyer
no flags Details

  None (edit)
Description rj_iyer 2002-12-01 08:09:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Compaq Presario 7000 series, usb keyboard.
Keyboard does not work when usb modules are loaded.
This causes installer to hang.
Nousb option does not fix it.
After installation with another ps2 keyboard nousb option works.
But Caps lock causes keyboard to hang for sometime and
keyboard tends to repeatedly enter keys even when im not pressing them. Another
keypress is needed to stop it.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do not pass nousb option.
2. Other problems with keyboard (with nousb option) occur randomly and on
pressing CAPSLOCK
3.
	

Actual Results:  keyboard does not work.
Or with nousb option many programs like mozilla, terms go haywire when enteing text.

Expected Results:  Keyboard should just work.

Additional info:

usb.c timeout messages occur when nousb option is not passed on boot.
Comment 1 Michael Fulbright 2002-12-02 10:59:23 EST
Sounds like a kernel usb issue.
Comment 2 Jelle Veldman 2002-12-06 04:46:20 EST
Accoording to an entry in another newsgroup, the problem is solved by using 
kernel 2.4.19 + a patch to 2.4.20-pre10.

http://mm.ilug-bom.org.in/pipermail/linuxers/Week-of-Mon-20021021.txt

Comment 3 rj_iyer 2002-12-21 13:01:32 EST
Thanks for the info.

Any idea exactly what is causing the bug?
And is there a place i can get a patch from 2.4.18-14 to 2.4.20 (i'm on a 
dialup)
Comment 4 Andre Luis Correia Schaumburg 2003-01-30 08:56:11 EST
So... How I can install a Patch if I don´t have a Redhat working...

Exist any param to put in initrd line of SYSLINUX.CFG?
Or exist other boot.img with this solution?

Thanks.
Comment 5 rj_iyer 2003-03-04 04:41:30 EST
Yes it does seem to be a kernel usb issue. I was able to find a workaround for 
it.

The solution was to compile the kernel with usbkbd.o (which follows HID boot 
protocol) instead of the generic hid.o driver. I tried this with the 2.4.20 
(plain vanilla) kernel but it should work with other versions as well. The 
kernel documentation actually discourages the use of usbkbd.o and recommends 
hid.o "unless you know what you are doing". So i think there is a problem with 
the generic driver not correctly working with my hardware for some reason.


Also i tried out a recent version of the knoppix bootable cd distribution. It 
seemed to detect and use my usb keyboard extremely nicely. But when i did a 
knx_hdinstall to install it on my harddive i found the exact same problem on 
bootup with the same timeout message and a dead keyboard.
I dont know why when i boot from the knoppix cd it works fine but does not work 
when i use the installed version.
 
So, atleast in the case of the Anaconda installer for RedHat linux, can you 
look into what you are doing differently from the knoppix cd for hardware 
detection? This will atleast let me install the packages even if i have to use 
a custom compiled kernel later on.

Thanks
Comment 6 Pete Zaitcev 2003-03-09 14:43:15 EST
Requestor, please test with 2.4.18-26.
Comment 7 rj_iyer 2003-04-09 12:46:44 EDT
Created attachment 91043 [details]
Kernel Log
Comment 8 rj_iyer 2003-04-09 12:52:55 EDT
I downgraded to RH 7.1 and installed 2.4.18-26.7.xcustom (built with hid.o).
It gave the exact same problems as the other kernels.
I've attached the kernel log for more information of the trial.
From the syslog:

kernel: usb_control/bulk_msg: timeout
last message repeated 15 times

The keyboard is dead as before.
Comment 9 Pete Zaitcev 2003-06-04 00:28:12 EDT
Anyone tried RHL 9 on that thing?
At least "nousb" should work during installs again.
Comment 10 Jelle Veldman 2003-06-05 07:40:12 EDT
V9 installs fine. I think it works because the default kernel of V9 is 2.4.20.
Comment 11 rj_iyer 2003-06-07 07:47:59 EDT
Hi,

I just got hold of RHL9 cds.
It still does not work, even with the nousb option.
The installer hangs at the screen where it asks whether to check installation 
media.

I'm thinking of modifying the redhat bootdisk with a kernel compiled with 
usbkbd.o and then try to install RHL9.

rj


Note You need to log in before you can comment on or make changes to this bug.