Bug 78822 - Kernel crashes with heavy network traffic
Kernel crashes with heavy network traffic
Status: CLOSED DUPLICATE of bug 69920
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-01 11:16 EST by abs01
Modified: 2013-07-02 22:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-09 09:06:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of running tasks/memory when this freezes (6.58 KB, text/plain)
2002-12-03 14:57 EST, Ian Holsman
no flags Details
kernel backtrace (2.80 KB, text/plain)
2002-12-09 09:02 EST, Michael Redinger
no flags Details

  None (edit)
Description abs01 2002-12-01 11:16:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; H010818)

Description of problem:
heavy network traffic will crash kernel every time. I updated kernel using 
up2date from version 2.4.18-10smp to 2.4.18-18.7xsmp. Pervious kernel did not 
crash.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Running a crawler I can index over 1.5 million URLs a day using old kernel. No 
problems at all.

Actual Results:  Running the crawler with the new kernel will crash the entire 
system every time. Only way to recover is power off. Tried several attempts 
with new kernel and can always crash it this way.


Expected Results:  Should not crash of course.

Additional info:

Using Dell PowerEdge 2650 4GB RAM, 2 Xeon 1.8, Raid 5, 3 Broadcom 10/100/1000.

What I think the problem is is the tg3 driver. That's the driver used for the 
broadcom ethernet cards and one of the things this new kernel changed. 

After the upgrade the system works fine under normal minimal system and network 
load. I ran the basic server for two days without any problems with the new 
kernel installed.

Crashing the server is easy every time simply by choosing 2.4.18-18.7xsmp 
kernel from Grub at startup and run my indexer. Obviously most people will not 
have this problem because they don't normally fetch 1.5+ million URLs a day 
like we do.

If I start the server using the 2.4.18-10smp kernel I do not have this problem 
and am able to index the 1.5+ million URLs as expected. So I have to believe 
there is a problem with the 2.4.18-18.7xsmp kernel as this is the ONLY kernel 
that causes this problem. All previous kernels used prior to this have not had 
a problem. According to the errata these were the changes made for this kernel:

77834 - Working Dos from bugtraq mailing list
69920 - Kernel Crashes in TG3 Driver
76171 - kernel-2.4.18-17.7.x update caused maestro3 to stop working
77138 - Sound Modules Fail for Enigma kernel 2.4.18-17.7.x on Dell Latitude
J750
76555 - problems with kernel-2.4.18-17.8.0 on Dell Latitude CPx
77565 - [gdth] NULL pointer dereference in scsi.c (scsi_release_commandblocks)
76233 - new kernel up2date hangs laptop at shutdown
77241 - esd peaks CPU w/ kernel 2.4.18-17.8.0 on Dell Inspiron 8100
77258 - Ethernet interface not working on SiS 963 south bridge (SiS 648
chipset)
77134 - Sound Modules fail for Enigma kernel 2.4.18-17.7.x
76385 - 2.4.18-17.7.x update breaks Wacom tablet support
75359 - kernel source does not compile due to missing include files
76624 - Segmentation Fault using GDTH on RH72 kernel-smp-2.4.18-17.7.x
76206 - xirc2ps_cs hangs apmd after upgrading to 2.4.18-17

So I have to assume the problem is with the "TG3 Driver" as this seems to be 
the main "network" updates that were performed.

Before deciding to post this bug I ran several tests with both kernels and like 
I said, I can crash the 2.4.18-18.7xsmp kernel every time, but with two other 
kernels available to me via Grub I can not crash the system.

Thanks,
Tony
Comment 1 Ian Holsman 2002-12-03 14:57:46 EST
Created attachment 87264 [details]
dump of running tasks/memory when this freezes
Comment 2 Ian Holsman 2002-12-03 14:58:48 EST
I'm seeing this as well (see attached kernel dump)
FWIW -- this was NOT happening on the -17.7.x version, only the -18 one
Comment 3 Michael Redinger 2002-12-09 09:01:17 EST
Same here.

Attaching kernel backtrace I found.
Comment 4 Michael Redinger 2002-12-09 09:02:06 EST
Created attachment 87964 [details]
kernel backtrace
Comment 5 Jeff Garzik 2002-12-09 12:17:24 EST

*** This bug has been marked as a duplicate of 69920 ***

Note You need to log in before you can comment on or make changes to this bug.