Bug 78825 - Serial line problems after upgrading from 2.4.9 to 2.4.18
Serial line problems after upgrading from 2.4.9 to 2.4.18
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-12-01 12:30 EST by Johan Vromans
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X server log, RH72, plain 2.4.20 kernel (9.16 KB, text/plain)
2002-12-02 07:09 EST, Johan Vromans
no flags Details
X server log, RH72, Red Hat 2.4.28-18.7.x kernel (9.03 KB, text/plain)
2002-12-02 07:10 EST, Johan Vromans
no flags Details
Output of lsmod, RH72, Red Hat 2.4.18-18.7.x kernel (2.70 KB, text/plain)
2002-12-02 07:11 EST, Johan Vromans
no flags Details

  None (edit)
Description Johan Vromans 2002-12-01 12:30:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
I'm running RH7.2 with all updates on Athlon 1600. One of my serial ports is
connected to a Wacom Intuos A6 tablet. I also have a PCI modem of type 536EP.
It's driver for the 2.4.x kernels is downloadable from
(Intel-536ep-451.tgz). All devices function normally when using the distributed
Red Hat 2.4.9 kernel.

After upgrading to the Red Hat 2.4.18-17.7x kernel, the tablet and the internal
modem stopped working. They also do not work under the Red Hat 2.4.18-18.7.x
kernel. For reference, they also do not work under Red Hat 8.0, with the
2.4.18-14, 2.4.18-17.8.0 and 2.4.18-18.8.0 kernels. Symptoms for the Wacom
tablet: the X server complains that it cannot read the driver information. For
the 536EP modem: it initializes normally, but generates timeouts during
transmission that cause the transmission to fail.

I've downloaded the standard 2.4.20 kernel source today and built it using the
config file that came with 2.4.18-18.7.x (I only changed the SCSI driver to be
resident). With this kernel, all devices function normally on RH7.2.

On RH8.0 and 2.4.20, the tablet functions okay, but the modem freezes the system
while receiving a fax. When it times out, the system continues to run normally
again. Note that this problem could be related to the fact that the Intel driver
comes with a precompiled driver module that causes insmod to complain about GCC2
drivers not working in a GCC3 kernel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot any of the mentioned Red Hat 2.4.18 kernels
2. Start hylafax and X

Actual Results:  Tablet is not working, and error messages are in the X server log.
When sending or recieving a fax the moden timeouts, causing the transmission to

Expected Results:  How about a working tablet and fax transmission :-).

Additional info:
Comment 1 Arjan van de Ven 2002-12-02 03:43:49 EST
you seem to report 2 independent problems here: you have a problem with a wacom
tablet and you use a binary only kernel module. Systems that have the binary
only kernel module linked in are very unsupported. Does the wacom problem also
happen when you don't have binary only kernel modules loaded?
Comment 2 Johan Vromans 2002-12-02 07:09:41 EST
Created attachment 87024 [details]
X server log, RH72, plain 2.4.20 kernel
Comment 3 Johan Vromans 2002-12-02 07:10:41 EST
Created attachment 87025 [details]
X server log, RH72, Red Hat 2.4.28-18.7.x kernel
Comment 4 Johan Vromans 2002-12-02 07:11:36 EST
Created attachment 87026 [details]
Output of lsmod, RH72, Red Hat 2.4.18-18.7.x kernel
Comment 5 Johan Vromans 2002-12-02 07:15:25 EST
Yes, I've tried that as well. I've created three attachments: the X sewrver log
on a working configuration (RH72 + standard 2.4.20 kernel), the X server log on
a non-working configuration (RH72 + Red Hat 2.4.18-18.7.x kernel), and the
output of lsmod of that configuration (to show that there are no foreign modules).

Please let me know if I can provide additional information.
Comment 6 Alan Cox 2003-06-08 15:39:02 EDT
Red Hat errata kernels are now 2.4.20 based, has that solved your problem ?
Comment 7 Johan Vromans 2003-06-15 12:45:45 EDT
I've replaced the intenal modem by an external modem, so I cannot feedback on
the modem part of the problem anymore. As for the tablet part: I tried the
2.4.20-18-7 kernel but had to go back to the stock 2.4.20 kernel due to USB
problems (see bugzilla 97424).
Comment 8 Bugzilla owner 2004-09-30 11:40:15 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.