Bug 78855 - /etc/init.d/nscd reload actually kills nscd totally
/etc/init.d/nscd reload actually kills nscd totally
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-02 01:31 EST by David Vu
Modified: 2016-11-24 10:01 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3.3-65
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 02:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Vu 2002-12-02 01:31:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
When /etc/init.d/nscd reload is given, nscd is killed totally and abnormally, 
instead of reloading the config?

This happens on both RH7.3 and RH7.1 using nscd-2.2.5-42 and nscd-2.2.4-31 
respectively.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ps -auxw | grep nscd to confirm nscd is running
2. /etc/init.d/nscd reload
3. ps -auxw | grep nscd to find no nscd running
4. /etc/init.d/nscd status
	

Actual Results:  3. No nscd process/thread present
4. nscd dead but pid file exists

Expected Results:  2. /etc/init.d/nscd reload sends a -HUP to the NSCD process 
which should alert it to close the log file, re read the /etc/nscd.conf and go 
on running.
3. nscd should still be running.
4. should say something like:
nscd (pid 7620 7619 7618 7617 7616 7615 7614 7613 7610) is running...

Additional info:

System armed with latest Errata RPMs.

This maybe related to the other nscd bugs where nscd crashes or dies 
abnormally, leaving behind /var/run/nscd.pid nd /var/run/.nscd_socket.
Comment 1 Ulrich Drepper 2004-10-06 02:07:03 EDT
This might have been the case in that old release.  Nobody checked
since this bug went unnoticed since the component was nscd not glibc
(nscd was never looked at).

The current nscd is much more robust.  For best results use the code
in the upcoming FC3 release of from rawhide today (2.3.3-65 and up).

I'm closing this bug since it's outdated.

Note You need to log in before you can comment on or make changes to this bug.