Bug 788592 - Review Request: rubygem-rbovirt - A Ruby client for oVirt REST API
Summary: Review Request: rubygem-rbovirt - A Ruby client for oVirt REST API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michal Fojtik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-08 14:41 UTC by Vít Ondruch
Modified: 2014-12-19 13:29 UTC (History)
4 users (show)

Fixed In Version: rubygem-rbovirt-0.0.6-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-25 08:29:22 UTC
Type: ---
mfojtik: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Comment 1 Michal Fojtik 2012-02-10 09:47:51 UTC
Review:

* Packages that contain Ruby Gems must be called rubygem-%{gemname} where gemname is the name from the Gem's specification.

OK

The Source of the package must be the full URL to the released Gem archive; the version of the package must be the Gem's version

OK

The package must have a Requires and a BuildRequires on rubygems

OK

The package must provide rubygem(%{gemname}) where gemname is the name from the Gem's specification. For every dependency on a Gem named gemdep, the package must contain a Requires on rubygem(%{gemdep}) with the same version constraints as the Gem

OK

The %prep and %build sections of the specfile should be empty.

OK (Patch is being applied, so %prep is not empty)

The Gem must be installed into %{gemdir} 

OK

gem install --local --install-dir %{buildroot}%{gemdir} --force %{SOURCE0}

OK

The package must own the following files and directories:
%{gemdir}/gems/%{gemname}-%{version}/
%{gemdir}/cache/%{gemname}-%{version}.gem
%{gemdir}/specifications/%{gemname}-%{version}.gemspec

It's possible to update guidelines to for excluding cache ^^ ? (not a review blocker)

=====================================


This package looks safe, license is sane and patching was properly described in a comment. REVIEW+

Comment 2 Michal Fojtik 2012-02-10 09:48:30 UTC
+ Can you please import this packages to EL6 ?

Comment 3 Michal Fojtik 2012-02-10 10:00:05 UTC
+ I would need this package for Fedora 16 too. Can you please import it with ruby(abi) = 1.8 and avoid the new Ruby RPM macros?

Thanks!

Comment 4 Vít Ondruch 2012-02-10 11:13:43 UTC
Thank you for your review. I'm going to request f16 f17 and el6. See bellow



New Package SCM Request
=======================
Package Name: rubygem-rbovirt
Short Description: A Ruby client for oVirt REST API
Owners: vondruch
Branches: f16 f17 el6

Comment 5 Gwyn Ciesla 2012-02-10 12:54:02 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2012-02-10 14:50:34 UTC
rubygem-rbovirt-0.0.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-rbovirt-0.0.5-1.el6

Comment 7 Fedora Update System 2012-02-10 15:01:26 UTC
rubygem-rbovirt-0.0.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-rbovirt-0.0.5-1.fc16

Comment 8 Fedora Update System 2012-02-10 18:37:37 UTC
Package rubygem-rbovirt-0.0.5-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing rubygem-rbovirt-0.0.5-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0421/rubygem-rbovirt-0.0.5-1.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-02-16 09:15:00 UTC
rubygem-rbovirt-0.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-rbovirt-0.0.6-1.fc16

Comment 10 Fedora Update System 2012-02-16 09:15:54 UTC
rubygem-rbovirt-0.0.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-rbovirt-0.0.6-1.el6

Comment 11 Fedora Update System 2012-02-25 08:29:22 UTC
rubygem-rbovirt-0.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-03-06 07:06:43 UTC
rubygem-rbovirt-0.0.6-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Troy Dawson 2014-12-18 23:34:55 UTC
Package Change Request
======================
Package Name: rubygem-rbovirt
New Branches: epel7
Owners: tdawson

Comment 14 Gwyn Ciesla 2014-12-19 13:29:12 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.