Bug 788602 - [eap6] securing EAP causes: Error in runtime discovery NPE
[eap6] securing EAP causes: Error in runtime discovery NPE
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-02-08 10:05 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 03:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug log (10.00 MB, application/octet-stream)
2012-02-08 10:09 EST, Libor Zoubek
no flags Details

  None (edit)
Description Libor Zoubek 2012-02-08 10:05:39 EST
Description of problem: I think, this is related to AS7 plugin, because this issue happens to me sometimes (mostly) when I run my AS7 testsuite.


Version-Release number of selected component (if applicable):
Version: 4.3.0-SNAPSHOT
Build Number: b4761de

How reproducible: hard

I am still not sure about the steps to reproduce, but this issue happens mostly when I run rhq-eap testsuite

This is, what my tests does
Steps to Reproduce:
1. have EAP6 standalone configured to be unsecured
2. inventory EAP6, do some start/shutdown
3. secure EAP6  - by adding some random user, enabling security and restarting it (I do that using SSH)
4. right after that (observed by timestamps) agent starts to throw NPEs
  
Actual results: when agent throws too much NPE it is not able to detect new resources (like adding datasource on EAP etc). Only way to get it work is to restart agent


Expected results:


Additional info: I know, this is not usual usecase, since EAP6 comes secured by default and the right way to inventory it is to invoke 'install RHQ user' operation at first

 attaching debug log containing NPEs
Comment 1 Libor Zoubek 2012-02-08 10:09:02 EST
Created attachment 560285 [details]
debug log
Comment 2 Libor Zoubek 2012-02-08 10:11:00 EST
here is the NPE

2012-02-08 15:13:15,960 ERROR [InventoryManager.discovery-1] (rhq.core.pc.inventory.RuntimeDiscoveryExecutor)- Error in runtime discovery
java.lang.NullPointerException
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.discoverForResource(RuntimeDiscoveryExecutor.java:239)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.discoverForResource(RuntimeDiscoveryExecutor.java:277)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.discoverForResource(RuntimeDiscoveryExecutor.java:277)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.discoverForResourceRecursive(RuntimeDiscoveryExecutor.java:158)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.runtimeDiscover(RuntimeDiscoveryExecutor.java:140)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:99)
        at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:56)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:636)
Comment 3 Libor Zoubek 2012-02-09 04:40:09 EST
hm .. so I've removed test, that is securing EAP6, and I still get NPEs on agent, I need to investigate more.
Comment 4 Heiko W. Rupp 2013-09-02 03:17:35 EDT
Bulk closing of issues that were VERIFIED, had no target release and where the status changed more than a year ago.

Note You need to log in before you can comment on or make changes to this bug.