Bug 78870 - missing openldap-devel dependency in sendmail-devel package
Summary: missing openldap-devel dependency in sendmail-devel package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 16:30 UTC by rm0
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-02 16:32:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
conftest.c (276 bytes, text/plain)
2002-12-02 16:32 UTC, rm0
no flags Details

Description rm0 2002-12-02 16:30:57 UTC
Description of Problem:
At least one function contained in the libsmutil.a static lib
shipped with sendmail-devel neds the `ldap_err2string' function
When one tries to build some piece of software that needs
libsmutil.a, the link process fails.

Version-Release number of selected component (if applicable):
sendmail-devel-8.11.6-15.i386.rpm

How Reproducible:
Always

Steps to Reproduce:
1. install sendmail-devel package (if not present), uninstall openldap-devel 
(if present). Note that installation of the first does not require
the second.
2. Try to compile the attached test file (conftest.c borrowed from an autoconf
script) using something like:
$ gcc -o conftest -O2 -march=i386 -mcpu=i686 -pthread   conftest.c -lsmutil
3. Note that the build fails.

Actual Results:
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsmutil.a(errstring.o): In 
function `errstring':
errstring.o(.text+0x25a): undefined reference to `ldap_err2string'
collect2: ld returned 1 exit status

Expected Results:
installation of sendmail-devel should have required previous
installation of openldap-devel

Additional Information:

This is the relevant part of a config.log file:
	
configure:2239: checking for errstring in -lsmutil
configure:2258: gcc -o conftest -O2 -march=i386 -mcpu=i686 -pthread   
conftest.c -lsmutil    1>&5
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsmutil.a(errstring.o): In 
function `errstring':
errstring.o(.text+0x25a): undefined reference to `ldap_err2string'
collect2: ld returned 1 exit status
configure: failed program was:
#line 2247 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char errstring();

int main() {
errstring()
; return 0; }

Comment 1 rm0 2002-12-02 16:32:15 UTC
Created attachment 87048 [details]
conftest.c

Comment 2 Florian La Roche 2002-12-02 21:54:22 UTC
openldap-devel is listed in the current rpm, so this seems to be
fixed.

Thanks a lot,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.